DNS problems with V6

As far as I remember, the VMC client application can be configured to use various parameters - static/dynamic IP, static/dynamic dns etc. - once set, these settings should be read by windows and applied to the registry, typically under:


Which is then read for the appropriate information by services that need network access.

For now, I have two options: stay with CISA V5, or disable the CIS Firewall Driver and use the Windows Firewall while I'm on the adapter.

If you don’t want to keep installing/removing version 6, just disable te driver and use Windows firewall.

By the way, is this an indication that the problem is not really a DNS server problem?

(CIS Firewall not selected):


Pinging with 32 bytes of data:
Reply from bytes=32 time=1120ms TTL=43
Reply from bytes=32 time=453ms TTL=43
Reply from bytes=32 time=613ms TTL=43
Reply from bytes=32 time=427ms TTL=43

Ping statistics for
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 427ms, Maximum = 1120ms, Average = 653ms

(CIS Firewall selected):


Pinging with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),


It’s obviously an indication that something is not working correctly but I’d guess this is just part of a larger problem, which, if solved, will also correct the DNS issues.

I'll be happy to heed any advise you may come up with, but even if you're at a dead end as well, thanks for all your efforts.

Can you remind me what settings you have in the VMC client application please?

bxf -

In comparing the two configuration files you posted here; I was just wondering if making the following changes would help any?
in v6 - HIPS - add the following two rules
C:\Windows\SysWOW64\atwtusb.exe assign predefined Ruleset of Windows System Application
C:\Windows\System32\taskeng.exe assign predefined Ruleset of Windows System Application

These two files are the only rules that show different between the two configurations.

If that does not help then maybe add the VMCLite application ( to HIPS ) as an Allowed Application.

Unless I’m blind, the application has absolutely no configuration options. None. Nada.

Please let me know if there’s something I should be looking at that would help answer your request.

Tried all of the above, to no avail.

Thanks for the suggestion.

I guess it depends on whether you’re using the full client or the ‘lite’ version. As I recall, it’s something that can be configured via profiles or manage connections… Sorry, I’m a bit vague, it’s been a while since I last had access to a VMC

My earlier failure to locate any settings was due to the fact that SETTINGS is not available when the connection is active. Anyway, I don’t believe the following will be of much help, but here goes (other available options in brackets):

Network Preference: All Networks (Roaming Networks Only; Home Network Only)

Connection Behaviour: Prompt (Off; Automatic)

APN: all blank

IP/DNS: all blank (available fields are DNS, WINS, IP)

Security: Unencrypted Password (None; CHAP; MS-CHAP v2)

The only thing I can add is that if I specify OpenDNS Servers, they get appropriately propagated to the connection settings. BUT, the problem still exists!

I can’t help but wonder the significance of the fact that the problem still exists when the Firewall is Disabled, but problem disappears when CIS Firewall Driver is deselected in Connection.

Unfortunately, it is beginning to look like like some sort of conflict between the CIS 6 driver and something running on the PC. I really wish we had another VMC to play with…

At this point I’m wondering if it’s worth reporting this as a Bug To do so, you’ll need to use this format

To be honest, I still can’t make sense of the fact that you appear to be getting a different IP config simply by installing an updated version of the firewall. I also wonder if it’s worth while post a query on a Vodafone help forum regarding the different addresses/masks being offered when connecting to the same APN.

to see… hell just uncheck the comodo internet security firewall driver on the properties of the adapter and see if it works. screenshot of what i mean attached. this will tell us something.

[attachment deleted by admin]

Thanks, but I’ve already indicated several times that doing this “solves” the problem.