dll file error

I was updating my Comodo Firewall and in the process an error window appeared
stating “Error while loading resources from C:\ProgramFiles\COMODO\Firewall\cfpconfg.dll. Aborting application” And ever since I can neither open the program or remove it to reinstall without the same error window popping up…any help out there?

Have you tried rebooting your PC?.

Check to see if the CIS processes are running (Ctrl+Alt+Del and click the processes tab and look for any cfp* named processes). I assume that they are there and it will be trouble to remove them since they usually can’t be terminated by the usual methods. You may be able to do it by booting into safe mode and using AutoRuns.exe (download from microsoft\sysinternals: Autoruns for Windows - Sysinternals | Microsoft Learn) to prevent the CIS programs from loading (uncheck all the cfp files found in the TaskManager listing from above). Reboot and run the uninstall program. I have not tried this, but it might do the trick. The next option involves editing the registry which is more hazardous.