I’ve noticed that new sites that use the disqus commenting system cannot load disqus comments at the bottom of their articles. There is just a spinning article saying that “Disqus seems to be taking longer than usual. Reload?” Reloading makes no difference. Same issue when add-ons disabled. Problem does not occur with IceDragon, IE9 or FF. Any clues?

Hi cavehomme,
Try disabling ‘Do not allow websites to know where you came from (suppress HTTP referrer header)’ found under privacy in the advanced settings.


Thanks Captain, tried that, also disabled most other things I can see including Comodo DNS. In Avast I have disabled the web and network shields and rebooted. It’s been happening for a while, also with Bitdefender. It’s a pain now because I want to use Dragon rather than Icedragon as default because of the speed differences.

I have not tired re-installing Dragon yet, will try it. Any other suggestions please?

Hi cavehomme,
Only maybe try clearing your browsing data.
I was not sure if you were logged into ‘Disqus’ for this issue to occur?
Since my last post I have tried reproducing the issue (Not logged in) without success, sorry.

Edit: You could try Dragon portable, this is independent from your installed version.
This would help eliminate any issues with your installed version.
Dragon Portable

I uninstalled and removed profile data, then CCleaner registry, then downloaded latest version and installed, seems to be working OK now, including with my adblock add-ons and default Dragon settings. Fingers crossed! Thanks for your suggestions Captain, I should have tried re-installing previously, sorry.

Hey no sorry required.
There is no harm in trying other things before a re-install.
Good to hear it working correctly. :-TU