Disabling/unscheduling a scan rule does not disable/remove its job. [M268] [v6]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic title, NOT here.

  • Can U reproduce the problem & if so how reliably?: yes, 100%
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
  1. Create new rule or edit default one.
  2. Set any timed scheduling.
  3. Check scheduled tasks in system panel.
    4a. Disable this rule.
    or
    4b. Set its scheduling frequency to “not schedule”.
    or
    4c. Remove scan task.
  • If not obvious, what U expected to happen: When disabling/unscheduling/removing a scan rule its *.job file should be disabled or deleted. Yet it does not and it got launched when the time comes (I had enabled full scan, then I disabled it, few moments ago scan got launched). Only schedule time is updated when changed. Also database check/update completly ignores settings (db: 3 days, app: 7 days) and check is on every CIS start.
  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version: none
  • Any other information, eg your guess at the cause, how U tried to fix it etc: unfixable unless job file removed manually.
  • Always attach - Diagnostics file, Watch Activity process list, (dump if freeze/crash). If complex - CIS logs & config, screenshots, video, zipped program (not m’ware) PM for pwd.
    [/ol]

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: 6.0.264710.2708, own

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: AV, FW
  • Have U made any other changes to the default config? (egs here.): yes
  • Have U updated (without uninstall) from a previous version of CIS: yes
    [li]if so, have U tried a a clean reinstall - if not please do?: no
    [/li]- Have U imported a config from a previous version of CIS: no
    [li]if so, have U tried a standard config - if not please do: no
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, & VM used: XP Pro, SP3, 32b, admin
  • Other security/sandbox software a) currently installed b) installed since OS: a) none b) none
    [/ol]

[attachment deleted by admin]

Edited B.7, if you would like to check :slight_smile:

You might like to see if a clean config or re-install would address this as you updated.

Best wishes

Mouse

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

Mouse

2801 - mostly fixed - enabling/disabling/unscheduling a scan now does update .job files, however CIS still launches AV update/version check soon after OS start and again after several hours.

THanks very much, tracker updated

however CIS still launches AV update/version check soon after OS start and again after several hours.
Could you do a separate issue report on this please Wilk if you think a significant problem for users, so we can discuss best fix for it, bearing in mind security issues

After some days testing here it is: https://forums.comodo.com/bug-reports-cis/cis-updates-every-os-start-t94988.0.html

Thanks very much Wilk, much appreciated

Can you please check and see if this is fixed with the newest version (6.2.282872.2847)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

It was fixed in 2801.

Thanks. I must have missed that.

I’ll now move this to Resolved.