Disabling Cryptography Signature check

I am a programmer, I am writing a program which connects with server using TCP/IP ptotocol. My compiler frequently modifies program I am writing. When I launch this program I get a message that my IDE modified memory of my program and than that cryptographic signature has changed.

I added rules for both IDE and my program but I get this message after each change of code. I tried to turn off signature detection but couldn’t find this option. Turning off application monitorig has no effect.

How can I disable check for this app without turning off whole firewall during my work time?

Any ideas?

I know others in your position have brought this up in the past; you can search thru the forum to see the exact details of it. Sorry, brain’s dead at the moment, can’t think of good search terms to use for the best results.

In the end, as I recall, the result was that at present, there’s no workaround. The controls are just too tight. You might get past it by turning off/disabling all aspects of Application Behavior Analysis, and possibly also turning the Alert Frequency down to Low or even Very Low. Very Low’s not a security risk as long as you’ve got ABA on; however, the ABA is probably the key for this type of thing. And even at that, it might not work.

That’s all I can think of, really. I know that setting “Skip advanced security checks” under the Misc tab of the application rule has been done, without success (as I recall).

You can try those things and see if they help. Hope it does. Rest assured, the developers are aware.


There was a request for a version just for developers ;). There is no current option to disable cryptographic checks. As you can see here I responded 51 days ago to this reply:


Thank you guys for your responce. It seams I have to wait for next version of Comodo. I like this program more than Kerio, pity it has no option for it.