disabled incoming IP but svchost.exe still asks about receiving connection

I have global policy rule to block all incoming IP traffic from anything outside 10.0.0.1/255.255.255.0 (which is my home network). However, when I travel I always get message boxes asking to allow svchost to receive a connection from the internet. The messagebox lists various ip’s like 10.254.16.9 or 192.168.0.1 - all of them are outside 10.0.0.1/255.255.255.0 range.

What is going on here ?

Thanks,
Sergey.

It’s probably worth posting screenshots of your application and global rules. Generally, if you’ve created a global rule that blocks IP In, inbound connections, other than those specifically allowed, will be silently discarded.

Yes you need to upload images of
1] rule
2] warning massage

or try using using stealth port wizard setting ,
Block all incoming connections and make my ports stealth for everyone.

[attachment deleted by admin]