Disable trusted vendors list

Currently (version 7.0.317799.4142) the problem referred in this thread persists.

Is there a way to definitely disable the trusted vendors list functionality in version 7 (instead of only deleting the entries in the list)?

Thanks

[ol]- Open main CIS GUI

  • Click Tasks in the upper-right corner
  • Expand Advanced Tasks and click Open Advanced Settings
  • Expand Security Settings and then expand File Rating then click File Rating Settings
  • Untick Trust applications signed by trusted vendors
  • Click OK[/ol]

Hello Sanya,

Although doing that avoids trusting applications signed by trusted vendors, it does not completely disable the functionality, as cavwp.exe still has some activity and the problem described before in the referred thread (being unable to remove “@Last Software Inc.” from the list) still persists.

I was hoping for a more aggressive solution for the problem, like deleting the trusted vendors database, however I don’t know its location.

Thanks.

For those interested, I’ve found the trusted vendors list, so it can be definitely removed.

It’s in %PROGRAMDATA%\Comodo\Firewall Pro. The concerned file is cisdata, which is an SQLite database. The vendors list is in a table in the database. If you delete the records directly in the database, they won’t appear again. I haven’t tried deleting the table in the database, but it should work as well, however comodo might throw some kind of error at you.

If you do this, or try this please sure to copy all files in that folder as you may have to replace them back or reinstall CIS.

I tried this in a earlier version and had to reinstall CIS as it was corrupt, I tried a few different ways on a VM and the only successful way was if I copied all files after install and replace them back.

Dennis

You try this:

You better have a full system image backup (not a Win SysRecv).

What’s going to end up happening if you get this wrong in the least bit, is CIS will get hosed and you’ll try to remove it and one the things that’ll happen just before you get it all straightened out: the Windows TCP / IP stack will become corrupt.

you need to understand how to fix that on the fly - you will not have IP-web access - after engaging whatever has been suggested and it doesn’t quite work.

Yep. Been there & done that.