Direct connect

hello

im running comodo internet security v6.0.260739.2674

i have trouble getting my direct connect client to download

i have tried everything i know and i have checked some guides on how to open ports in the comodo firewall, but it dont work even with the ports open

i have tried to disable the firewall by right click in the tray icon and when i do that the download works without a problem!

what do i have to do , to download with the firewall active?? (of corse i dont want to disable the firewall everytime i want to download something)

I thought i got it to work, but i was wrong.

Still not working. Cant download when firewall is active. If i disable the firewall download works great.

Anyone have a clue?

Ok so now i have finally solved it

I had no idea about the GLOBAL RULES

You have to go to GLOBAL RULES and switch the BLOCK IP IN to ALLOW IP IN

Yes, but you should make ingoing allow rules as specific as possible. As they are not needed for many things, but could lead to “trouble” or questions about other ingoing attempts.

Not quite; you just disabled the firewall…

You need to make rule(s) in Global Rules:

  • to allow all traffic from all ports and all source addresses with destination address Any (or specifically your pc) and destination port (TCP and port number)
  • to allow all traffic from all ports and source addresses with destination address Any (or specifically your pc) and destination port (UDP and port number)

Make sure the new rules are somewhere above the block rule as rules get read top-down.

ok not good

i will follow your steps, i guess i should block ip in again, in global rules?

and make new rules in global rules, as you suggested?

The basic set of Global Rules looks like in the attached image. Notice the block all rule at the bottom. Make sure you edit the allow IP rule to get that rule back.

Then add one or more rules as described in my previous post. After making a rule it may be placed under the Block rule. You need to then drag and drop it to a place above the Block rule.

[attachment deleted by admin]

Thank you so much moderator

I blocked IP in again, and open ports under global rules, followed what you said and moved the rules over the block ip in rule, and it’s now working like a charm

I did this before, the only mistake i did here, was to not move the open ports rule over the block ip in, thats why it didnt work hehe

thanks again for your help and your awesome free security suite, i really love this new version :slight_smile:

Oh and a happy new year to you all :smiley:

Glad it worked out.

I just saw I forgot to add the image to my previous post and added it… 88) :smiley: