Diagnostics reports problem

Just updated to 5.9.219863.2196 with database 11196.
Ran the diagnostic – It stated that there were installation errors.
CIS could not fix the problem. I looked at the diagnostic report - did not understand a thing.
help…

Can you please post exactly what the diagnostics said was the problem?
Also, did the installation complete without errors?

Thanks.

“The diagnostic utility has found some problems with your installation. Would you like to fix them?”
YES
“Could not fix some of the installation problems”

At the very end of the installation it stated that there was an error but did not say what.
Thanks

Found this in the diagnostic file:

Can you please zip and attache the full report?

Here is the requested attached file.

[attachment deleted by admin]

Besides reinstalling I see one option we could try.

Can you open a command-box as administrator (else it will fail). Next type the commands below:


Cd "\Program Files\COMODO\COMODO Internet Security\"
regsvr32 cmdaruns.dll

Next reboot. Maybe that could solve the issue, if not it’s time to uninstall / install.
But make sure your other Security softwares are not interfering with the installation, I see you have several others running that maybe could interfere here or there.

Unfortunately the command did not work.
I uninstalled and installed — things seem to be working now.
I am really glad that I remembered to save my configuration before the uninstall.
Thanks for the quick help.
Bob

Hi,

I have exactly same issue since yesterday - Diagnostics Errors which can not be fixed, but CIS seems to work fine.

Tried registering cmdaruns.dll as well as complete uninstall/re-install, but did not work.

Attaching 2 jpg files and xml report.

As I remember, this issue started when I purged Trusted Files, Network Security and Computer Security. In case of Trusted Files and Network Security (I think so - in two of these procedures any way), a blank line (no details about entry) was presented for purging, which I did purge. Maybe that set off this issue in some way.

Thanks & Regards,
Rad.

[attachment deleted by admin]

Hi radhx,

Yours is a different issue, something seems to prevent CIS from registering it’s appinit_dll.
Do you have other security software active during install that might cause this?

[attachment deleted by admin]

Hi Ronny,

I am using AVG Anti-virus along with CIS for past few years. That is the only other security software I am currently using.

Few weeks back I had to re-install CIS due to taking wrong update steps, but that time this issue did not arise though AVG was active all through uninstall/re-install procedure.

Thanks & Regards,
Rad.

AVG might have removed it later-on in a ‘scan’
If you trust your self around regedit you can ‘restore’ these settings manually.

Hi Ronny,

Please let me know steps for restoring these settings manually as I can handle regedit.

Thanks & Regards,
Rad.

This should be there.

Please be aware that if there are other entries there it needs to be added to it, I need to verify if there should be a separator of any kind then.

[attachment deleted by admin]

That is the problem key.

When I try to open My Computer\HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows

it says “Cannot open Windows: Error while opening key”.
All the options under right-click->New are disabled.

Any way to restore this key?

Thanks & Regards,
Rad.

Seems something gone wrong with your permissions, or you are not running regedit as administrator.
Can you select the ‘Windows’ Key and then Properties, Permissions.
See if Administrator has ‘Full Control’ access.

[attachment deleted by admin]

Yes, something has gone wrong with my permissions. I am one of the Administrators but still I can not change/add users to this key. There are no users defined for this key. I tried with logging in as original Administrator but still can not add users to this key.

I have a restore point as of Jan 10th. Also, a registry backup as of Jan 7th.
Is it advisable to try restoring one of these?
I have installed/updated few applications as well as Windows updates.

Thanks & Regards,
Rad.

You should be able to take ownership if your Admin.

Go to permissions again and press ‘Advanced’, switch to the tab owner, select the new owner from the lower window and check “replace owner on subcontainers and objects”.
Now after you apply this close Regedit and try again to change the permissions to full control.

I tried the specified procedure where on applying changes, it still denied access. When regedit was closed and re-opened, the windows key was accessible now (right-click->new options being available), but if tried to create a new key, “error creating key” message was displayed.

Again going back to permissions for Windows key, I noticed 2 “Deny” entries at the top for “Everyone” regarding “Full Control” and “Special” respectively which were not inherited. Removing those 2 “Deny” entries and applying the changes did the trick.

The Windows key stated displaying its various components along with the required guard32.dll which was already present, but not being displayed (accessed) because of those 2 deny entries.

I tried diagnostics and it is working fine now - not reporting any error for the installation.

Any ideas how these 2 deny entries got/can get there in Windows key? I don’t know how many other keys might have got these deny entries. Any way to check this?

Thanks & Regards,
Rad.

This tool from Sysinternals should be able to help you out.