Diagnostics report fails to save the report [M821]

[u][b]Edit: Full Dump can be downloaded here: MEGA

1. Diagnostics report as attachment to your post

Uhm… I can’t… that’s what this bug report is about…

Developers will absolutely give NO attention if this item is missing in a post.

So how are we supposed to file bug reports for the diagnostics report if we need a diagnostics report for it the be seen but we can’t make a diagnostics report because there is a bug with the diagnostics report… You see where I’m going with this?

Edit: I am now magically able to make diagnostics reports again so will attach it.

2. The full product and its version e.g. COMOOD Firewall 7.0.308911.4080

COMODO Internet Security Premium 7.0.308911.4080 BETA

3. Your Operating System (32 or 64 bit) and Service Pack revision. and if using a virtual machine, which one.

Windows 8.1 64bit. (real system)

4. List all the configuration changes you did. Are you using Default configuration? If no, whats the difference?

Too many to mention, will attach a config file.

5. Did you install over a previous version without uninstalling first, or import a previous configuration file? (please try to avoid doing these things until we are told it is safe)

No, and no. Clean install and new configuration file.

6. Other Security, Sandboxing or Utility Software Installed

OpenDNSCrypt | Zemana AntiLogger Free

7. Step by step description to reproduce the issue

I have no idea… make a diagnostics report? :S

Basically here is a time-line:

[ol]- I installed CIS 7 beta

  • I made a snapshot off the system (lets call it Snapshot 1)
  • A few hours later I made a bug report here that has a diagnostics report attached…
  • Now a day or two later I made another bug report, issue is that I can’t create a diagnostics file… (Edit: I am now able to create a diagnostics report and have attached it to that bug report and this bug report)
  • I make another snapshot which we will call Snapshot 2
  • I restored Snapshot 1 (Which I took BEFORE the first bug report which was ABLE to make a diagnostics report)
  • I try to make a diagnostics file… still can’t save it… Which really boggles my mind because my system is at this point EXACTLY like BEFORE the initial bug report where the diagnostics report WORKED… WHAT?! :o
  • Sit in my chair for a few minutes thinking “WTF”
  • Restore Snapshot 2 and make this bug report.[/ol]

(Snapshots made and restored with AX64 Time Machine)

8. What actually happened when you carried out these steps

Well the diagnostics report failed… and it even failed at a snapshot that was taken literally before I made a diagnostics report… if that makes any sense.

Edit: I am now magically able to make diagnostics reports again which is really weird so it seems to be this is an intermittent issue that manifests itself at random times. I’ve made a video explaining the timeline here: https://www.youtube.com/watch?v=I1zmAbAV_6Y

9. What you expected to see or happen when you carried out these steps, and why (if not obvious)

I expected the diagnostics report to be saved, at least I expected it to be saved after restoring the snapshot.

A video showing this issue can be watched from this page.

[attachment deleted by admin]

I have to admit. The video was funny. Isn’t it always the way it works. When you go to show someone how something was working for you it magically starts working again. ;D

Anyway, as this is intermittent I think the best thing to do is if this fails to work again open KillSwitch, then make a Full Dump. Then upload that to a file sharing site (such as this one) and paste the download link in your first post. This will ensure that whatever intermittent problem is causing this, it will be caught for the devs to examine. This is very strange, but I believe that doing that should give them enough information.

Thank you and let me know if you have any questions.

How do I make a full dump with KillSwitch?

Open KillSwitch. Then right-click on any of the processes (it doesn’t matter which one). Then go to “Create Dump”, and from the drop-down menu select “Create Full Dump…”.

Alright, when (if) it happens again I will create make the full dump and upload it to Mega, figured it was a bug since I’ve seen other people having this same issue.

Others have had this issue, along with others. However, there is not yet a bug report specific to this problem. Having a full dump should ensure that they have enough to fix this for everyone.

Thanks.

I actually logged this in parrallel so it has an M number 821 - just to tell you!

Thanks for reporting this Sanya.

??? I have no idea what that means… :embarassed:

Message to Chiron LOL

Oh!

You don’t have too :smiley:

I’ve added the full dump to the first post.

Also, I’ve come to the conclusion that this is truly “random” I just ran it like 20 times in a row and half of the times it failed and half of the times it worked… no pattern whatsoever.

To Chiron or others, could you try running and saving the diagnostics report 20 times in a row and see if you get this save fail issue and if so how often?

I have just tried…And got “failed to save report”.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

The devs have been unable to replicate this issue. If anyone is still experiencing this issue, the devs have asked that I request you to make a video showing the problem.

Thank you.

I’m no longer able to replicate this. ??? Well that is weird… Uhhh… I’ll make a video if it happens again. :-[

Thank you.

If anyone else is able to replicate this please let me know.

faceplam Wanted to hit preview but accidentally hit post… But yeah the above video shows the issue happening, please note that it might still be uploading/processing, in that case please wait a few minutes.