Diagnostics for 276 version

I am running the 276 version but when I run the diagnostics it shows that there are problems that it cannot fix. Everything seems to be working as far as I can tell. What can I do? I uninstalled it and reinstalled it with the same results.

When you uninstalled it did you run a registry cleaner afterwards?

This is usually a good idea, one of the easiest to use is the one included in the free CCleaner application.

Also, you might be wise deleting any Comodo Firewall folders in Program files and Documents and settings. Some of the folders are likely hidden in the ‘Local Settings/Application Data’ folders so you may have to ‘show hidden files and folders’ in folder settings.
After deleting these and running a registry cleaner you can then try re-installing the firewall. Also, perhaps you should download the installer again in case the one you have been trying is corrupted in some way.
Before installing you must turn off any realtime antivirus scanning and disable any other security software you have running.

If you have tried all this and still have problems then post again here and we will try to help.


I have disabled anti-virus, ran ccleaner, uninstalled firewall, removed references in documents and settings and I am still getting problems when I run diagnostics. From all indications the firewall is operating OK though.

Where can I download the 273 version and see if it will work?

When I install the firewall it shows that system security monitor is installed but it is not. I think this is why it shows a problem when I run diagnostics. How can I ensure that all system security monitor files are deleted?