Hopefully this will be simple, I’ve had a look round and can’t find anything specific.

For reasons that are beyond me, my PC seems to want to renew it’s IP address about once a day (it always gets the same one, cuz that’s what I told the router to do).

Unfortunately Comodo seems to block DHCP, since whenever it happens, I just lose connectivity until I switch on “Allow all” and do a manual IPCONFIG /RENEW

I’ve added a Network Control Rule to allow all IP traffic FROM TO on all ports, and put this at the top of the list, but it hasn’t helped.

Apart from this one niggle, I’m loving Comodo. Can anyone help?


If you add always the same IP you can configure windows to give at your connection a static IP without getting it from your DHCP server.

Edit: I just saw its your first post. Welcome you to the forums of comodo (:WAV)

Interesting… I tried that with my WiFi laptop earlier, and it didn’t work.

On the wired desktop it seems to be fine…

That was easy. Cheers ;D

Edit: I just saw its your first post. Welcome you to the forums of comodo
Thanks! Glad to be here.

The Problem may relate to Comodo Monitoring DNS Queries. Go to the Security>>> Advanced tab and uncheck (Monitor DNS Queries) and see if that fixes the problem. Alternatively, if your using WPA-PSK your wireless may be re-connecting to your Wireless Router every time it renews the Pre-Shared Key. The Pre-Shared Key reregister problem is something I’ve still got problems with whereas I don’t have any problems if I use WEP. You may find more information under the FAQ Topic in THIS forum. There’s a post about securing your wireless connection…

Hope that helps…


Hi Eric,

The BETA version has this problem fixed. So the releases after the beta versions will not have this problem while DNS monitoring is enabled.