DHCP and WAP on different IPs, Firewall blocks DHCP - how to fix?

My gateway/DHCP are provided by a PC running Astaro firewall. The wireless access point is from a dd-wrt router configured as a switch. When a client PC tries to connect wirelessly, they DO connect to the WAP but are never assigned an IP address, even if the Comodo firewall security level is set to training mode. I’ve added a global rule to allow all ports, TCP and UDP on all possible IP addresses from the DHCP server. That didn’t help. Comodo firewall must be fully disabled to receive IP address assignments.

Will someone please tell me how to fix this?

Hello Fred Thompson,

Could you try disabling “Block fragmented IP Datagrams”
CIS > Firewall > Firewall Behavior Settings > Advance

Also; If this does not work, could you could try applying “Alert me to incoming connections and make my ports stealth on a per-case basis”
CIS > Firewall > Stealth Port Wizards

Also; Do you have IPv6? or IPv4?
If you have IPv6 You may need to enabled IPv6 Filtering
CIS > Firewall > Firewall Behavior Settings

Also (Last but not least)
Could you check your Firewall Events (If any items are listed please post a screenshot on your next reply)
CIS > Firewall > Firewall Events

Hope this helps :slight_smile:


I’ve looked at your linked post which describes a custom network control rule.

That post shows as the destination IP address.

Is that actually supposed to represent the IP address of the DHCP server which is referred to as a.b.c.d in the ipconfig /all status from the top of the post?