Desktop freeze

Desktop freez with Comodo firewal 5.x und Windows 7 Ultimate x64

  1. What you did:
    When an application is run for which no firewall rule exists the firewall freezes the desktop on the 4th or 5th popup
  2. What actually happened or you actually saw:
    A frozen desktop without an alert box
  3. What you expected to happen or see:
    An alert box
  4. How you tried to fix it & what happened:
    Removed the predefined “trusted vendors” list → turned down the frequency of freezes. Tried to define rules for every app before i run it → less freezes. Turn off the Defense → almost no freezes

5-6 don’t apply

  1. Whether you can make the problem happen again, and if so exact steps to make it happen:
    At least i think the problem is associated with “unknown” applications. Coded an app with defined behaviour that steps through the different defense mechanisms/subrules (keyboard access, protected registry-keys, etc.) The logs show that the application can do 4-6 pop-up generating tasks before Comodo Firewall freezes the system.

  2. Any other information (eg your guess regarding the cause, with reasons):
    Nope.

  3. Crash or freeze dump file: The firewall logs are missing the last 10 minutes before a freeze. W7 doesn’t generate logs.

Your set-up

  1. CIS version, AV database version & configuration used:
    Latest Comodo (downloaded 08th/nov/2010

  2. a) Have you updated (without uninstall) from CIS 3 or 4, if so b) have you tried reinstalling?:
    Update kille my old rules. So i did several re-installs.

  3. a) Have you imported a config from a previous version of CIS, if so b) have U tried a preset config?:
    First attempt: yes. Second attempt on a clean system.

  4. Other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here. )

  5. Defense+ and Sandbox OR Firewall security level:
    Firewall: Own ruleset (Eigene Richtlinie)
    Defense: Secure Mode (Sicherer Modus)

  6. OS version, service pack, no of bits, UAC setting, & account type:
    Windows 7 Ultimate (fully patched, date 10th/nov/2010), x64, Default UAC-level, account: default user account. Firewall installed with admin.

  7. Other security and utility software installed:
    Eset NOD32 4.x, Secunia PSI on demand.

  8. Virtual machine used (Please do NOT use Virtual box):
    None on this machine


We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

WHY WE ASK YOU TO FOLLOW THESE GUIDELINES
Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation

Dennis

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

Have you disabled Windows firewall? If you haven’t please do so. Make sure that NOD32 and Comodo firewall do block each other or anything like that.

Do you only have ESET AV or do you have ESET Smart Security?

Tip: Have only one AV and one firewall active. (Immunet is an exeption; it’s a secondary AV that works together with your current AV.)

Regards,
Valentin

Desktop freeze is a very common problem with Comodo Firewall 5.0.163652.1142 x64 installed on Windows 7 Ultimate x64. It will also freeze whenever I run the game.

But this never happen to Comodo Firewall 4.1.150349.920_x64.

Thanks.

Yes, noticed that to. Don’t find my old 4.x-dl… sigh

My computer freezes when I want use it again after being inactive for a longer time. But i don’t know what is causing this.

Regards,
Valentin

Some of the features just cannot simply turn OFF like “Sandbox” and “Defense+”. They will hang the computer also whenever I run some of my games.

That’s so terrible BUG in the x64 edition on x64 Windows 7. But still never happen to Comodo Firewall 4.1.150349.920_x64 WHY ??

Currently I removed version 5.0.163652.1142_x64 and installed back the 4.1.150349.920_x64 on my Windows 7 Ultimate x64 edition. At least now my PC back to normal, no more hang no more abnormal behavior. Although there are some minor BUG available, but this can be easily counter. So it’s not a matter for me.

Will wait for at least 2 updates on the version 5. Then I will only install on my PC.

Thanks.

Thanks for the very useful bug report in standard format.

a) Could you please append your test app you refer to in first section number 7.
b) Could please try uninstalling ESET and see if the problem resolves

We need you to do a) if we are to forward this to format verified, as the devs will need to reproduce this. We’d prefer you to do b) as well

Many thanks and best wishes

Mouse

You can turn these off…

Right click on the taskbar icon. Select either D+ or the sandbox and disable them.

I’ll test a system run without eset on weekend (as i remember there has been a bug in the 3.x version of eset with the old version of the Comodo Firewall - but that caused a total block of internet connectivity on the local machine).

The test-application is based on some internal routines which i’ve developed in a team. When the other team-members agree i’ll post it. In more detail: you can tell the app which special action it should perform on a windows system, i.e. “get access to a registry key” or “try to resolve a domain name”. And then it does :wink:

I know it can be turned OFF. But when I turned OFF those 2 features and I run my game, my PC freeze.
So I have to let the features turned ON and then run my game. In my case, I’m seems being forced to use "Sandbox" and “Defense+”.

Thanks.

Thanks any feedback?

Best wishes

Mouse

PM reminder sent

Unfortunally i’m not able to supply the test app. If there are questions for functionality (it functions the way that you can specify an action like “access a registry key” or “access memory”. Modified that to provoke several firewall/defense-popups for this app)

Tested this on a clean system, after reinstall on my computer, another computer x64/W7Ult. No change.

Thanks for testing on a clean system - please confirm this was without ESET.

Re the test app, we need something to help devs replicate this. Two possibilities:

  1. I’ll PM you my email, and you can send the test app. Then I can append it to a report in the private (mods and devs only) bug tracking system
  2. You could give text ‘steps to replicate’, just describing a manual sequence that always causes it to happen

Could yo manage either 1) or 2).

We’d appreciate it if you could as this freezing issue is very difficult to track down.

Best wishes

Mous3

Unfortunately we do need this issue to be reported in the right format, and with all the information we have asked for, if we are to forward it to verified issues.

For the moment I am going to move it to the Orphaned/Resolved child board. If you do manage to edit your post to create a complete issue report in standard format, and PM an active mod, we will of course consider moving it to verified reports.

The devs only look at the Orphaned/Resolved board if they have time, so please do edit the post and PM an active mod if you want it fixed.

Best wishes and many thanks in anticipation

Mouse

I had this same problem a couple of weeks ago. A keypress could take a few minutes to be recognised. I eventually spent about 4 hours waiting for key presses and mouse movements and eventually killed as many processes as possible until only cmdagent was still running, which I obviously couldn’t stop. I was unable to use the computer enough to uninstall Comodo so I did a fresh install of Win 7 Pro x64. Ran it for two days without Comodo with no problem, installed Comodo and was back to square one. I went through installing Windows and Comodo again to satisfy myself that Comodo was causing it. I have now been running Agnitum Outpost for two weeks with no problems. I’ll come back to Comodo when this problem is fixed.