Dell fingerprint reader stopped working

I updated my Comodo Firewall Pro today to the new Internet Security 3.5 by first uninstalling CFP and then installing Internet Security. Everything works just fine except for the fingerprint reader.
The reader worked fine with CFP. I’m running Vista Ultimate SP1 on a Dell Studio 1535.

When the logon screen comes up the fingerprint icon says “Detecting reader …” and never finishes.
When I log in with a password the Digital Persona icon in the lower right corner has a white-on-red X on it
and when I try any actions with it it says Fingerprint reader not connected.
I’ve tried to reinstall the driver and the device manager says everything is ok but it till doesn’t work.

Any ideas how to fix this?

Be Data

Have you added the components as trusted in: Defense+\Advanced\Computer Security Policy ? You can do that by Editing and Treating it as a Trusted Application.

Also please provide your OS & Security Software installed.


This is a bit strange but the problem solved itself, sort of …

Yesterday, after having re-installed the driver for the fingerprint reader, I was asked to reboot which I did
but the reader still didn’t work. Actually I did a number of reboots.
After reading your response I went into the Device Manager to try to figure out which files I might add
to the Defense+ Computer Security Policy. But then I got this popup again that my hardware settings had changed and a reboot was required. I rebooted once more and the fingerprint reader started working!

My setup is as follows:
Dell Studio 1535 with 4GB RAM and Intel Core2 Duo 2.5 GHz processor running Vista Ultimate SP1 32bit.

The fingerprint reader is an AuthenTec AES2810.
The driver is version and consists of two files,
…\system32\drivers\ATSwpWDF.sys and

The fingerprint authentication is handled by DigitalPersona version

When I installed CIS I deselected the Antivirus component since I already have AVG Free 8.0.175 installed.

So my problem is solved but the question remains, why did this have to happen at all?
CFP didn’t cause any problems like this. I know my way around Windows pretty well but how would
the “average user” handle this? Or maybe the “average user” doesn’t install Comodo? :wink:
And even for me it was not self-evident that I would have to add anything at all to the firewall settings
for a hardware component and even less which files to add
(the driver files and/or some fiiles from DigitalPersona).


Probably a minor D+ bug. I guess it’s worth leaving this thread active anyhow when developers get to read this.