deletion of blocked files

Hello. Once you places files(s) in blocked how do you delete from computer. “remove” seems to return to disk. What does purge do? I tried help files but could not find answer. Thank you.


The option Remove will take the item off the list, and Purge will delete non-existent items. To delete a file in My Blocked Files from your computer, mark the file, and click Delete File.

I didn’t specifically add a file to My Blocked Files, I mistakenly told it to block an executable file. Now every time I try to start that executable I get an error message. I’ve tried adding it to My Safe Files but nothing works. There’s no reference to that file in My Blocked Files and I’ve looked everywhere else I can think of. Please help, this is the Mobi Reader and it’s perfectly safe.

Bumping this topic, someone PLEASE reply!

It’s the Defense+ settings that are causing me grief. If I disable them I’m able to use the Mobipocket Reader on my PC with no problem. If enabled, though, I continue to get a message that the application (reader.exe) has “encountered a problem and must close.”

During initial execution of this app, Comodo threw up two alerts, once concerning an attempt to connect to the Internet and one concerning modification of a file (a registry file, I believe, though I’m not certain. I didn’t pay that much attention.). There is no mention of this file in the “My Blocked Files” list and I can’t find anything else anywhere that contains any directions to block this file.

Please help! This isn’t the first time I’ve had this problem and the only option I’ve had was to either discontinue using the file or uninstalling Comodo and starting from scratch, which is quite a pain, as I then have to deal with countless “learning” alerts.

Please, someone, tell me where Comodo stores its record of what files it has “learned” to block so I can delete the notations about this particular app. Thanks!

Found the answer in another thread, quite by accident. For anyone else having this problem, the answer is in the Registry. I used TuneUp Utilities’ Registry Editor to search for the file name I was having trouble with, and it found it easily. I deleted the entries it found for that file and all is well now.