Defensive+ and blocking MSHTA.EXE by accident........

Was going to change my password for my log in information. When i double clicked on users. A prompt came up about rundll32 and allowing mshta.exe I was not sure what it was and blocked it. Now I cant get to the user options to change passwords, names etc. How do I undo this and allow mshta.exe again? I chose to block it since it did not really know what it was and it said it could be a dangerous script or some thing. Now I looked it up online and it says its a MS file. But it can be a browser hijacker or something.

Assuming that you used a remember setting, I’m pretty sure the method is to go to the firewall control window then go to the defense+ tab → advanced on the side bar → computer security policies then locate mshta.exe on the list (should be near the bottom) and simply right click and choose the option to remove it.

Removing stuff from the list basically force another pop up on the next occurrence of the removed programs.

I did tell it to remember. I tried your method and its not in that list. Weird.


I just went ahead and removed rundll32 and then tried. I got the prompt and allowed it to go through. I got a few other prompts. Saying it was dangerous because it could allow someone to take a screen shot or read key strokes. Whats that all about?

Hiya KoRn,how you doing,

If you do it again try this,
Defence+/advanced/Computer Security Policy/Find rundll and right click/choose edit/access rights
A new window will appear called Process Access Rights,at the top you will see “Run an Executable” with a tab opposite saying Modify.Clicking on Modify will bring up a window with Allowed and Blocked Applications.
Look in the Blocked Applications section and remove what you blocked.

Nice 1 Matty :■■■■