Defense+ x64 Fullscreen Game Freeze

When I try to start up (most) fullscreen games, both of my monitors go blank and my computer becomes unresponsive.

My computer:

Manufacturer: Hewlett-Packard Company
Model: HPE-180t
Processor: Intel Core i7 950 [at] 3.07GHz
RAM: 12 GB
0S: 64-bit Windows 7 Home Premium

For a while I’ve been having a problem when trying to start up most of my games, my computer simply decides to go black screen and not respond to any of my inputs (including CTRL-ALT-DEL)

After a while, I realized that the games all work just fine if I first disable Defense+ (Firewall + Antivirus are both still active) before opening them.

This bug happens when I try to start the following games:
Age of Mythology (w/ Titans Expansion)
Age of Empires III
MapleStory

But for some reason, it doesn’t happen when I try:
Fallout 3

I already tried telling Defense+ to treat AoM as a “Trusted Application” but that didn’t change anything.

All three of the games that crashed are “older” games, dating back from 2006 and earlier, if that matters.

Also, I believe AoM makes another file and executes it as a helper process, or something along those lines. Whenever I start it, before my screen goes blank, I get an alert about ~flosk (or something along those lines) trying to access aomx.exe (the game) in memory. I said to treat it as a Trusted Application.

Also, this only happens when I start the games in fullscreen mode. If I use Dxwnd to launch MapleStory (Dxwnd forces MapleStory to open in a window) then everything’s fine.

I’m not sure what else would be useful information. Whatever’s wrong, I’m 100% it’s at least related to Defense+, seeing as disabling Defense+ always makes all of the games work.

PS: If it matters, I’m running two screens. One HP monitor and using my TV as a secondary monitor.

It’s not a giant problem, but rather annoying to have to remember to disable Defense+ every time… and having to restart my computer every time I forget.

First try one of the two solutions to try to solve the issue:

  • When you know your system is free of malware follow A note to ganers
  • Make all .exe and .bat files in the installation folders of the games part of My Own Safe Files

In both scenarios the firewall will learn the rules automatically. Does that fix the problems for you or does it persist?[/list]

I know this has been said many times before, but: “A note to gamers” is stupid. Why? Because it’s a workaround that essentially bricks your computer for several minutes.

The logic: Comodo wants to protect my computer. NOT making me able to communicate with the computer at all is not helping. Not being able to kill Comodo, or the game is not helping. Being in hurry, having to make a HARD REBOOT is not helping.

I’m sorry I’m bitching, but the point of a firewall is to make my life easier, not to constantly bug me and make me aware of its existence. Having to remember to change Comodo into a training mode, or explicitly whitelisting their executable is user-unfriendly and actually lazy on the part of the developers. (Not saying it’s easy to make software perfect.)

Win7 x64
AMD Phenom X2 550
ATi HD4670
etc

kthx

Hi,

I agree, I have the same problem and it is pure ■■■■■■■■ >:(

Even setting the game as safe doesn’t prevent the ■■■■ freeze.

I say it again but it is pure ■■■■■■■■. I never seen that before.

I seriously consider uninstalling Comodo and shifting to ZoneAlarme.

I am tired of ■■■■■■ programmes.

Sorry for anger

Why Its so hard simply make the popups appear over the game?
I have seen taht other security sofware can do it, why dont comodo?

Straight from the horse’s mouth:

have any info futher for

game mode, like off defense+ when fullscreen …,trusted vendors?

I have no clue at all. Just wait and see what it will be.