defense +/system 32/rundll 32.exe

I am getting a stream of “Defense + is learning” notices.
So far it has been popping up for an hour.
Can somebody please advise as to how i stop it.
My settings are Antivirus—Stateful.
Firewall----Safe Mode
Defense ±-Clean PC Mode.
Configuration.-----Proactive Security.
Maybe my settimgs need changing.
Could an informed person please advise.

Operating system—Windows 7 RC
Other Security–AVG Link Scanner.
Thanks and Regards

Hi rambo,

first thing to do is make sure this is a genuine rundll32.exe. As I’m sure you are aware, there are a number of rogues that use this handle.

Second thing, what are the details of the events you are seeing?

Thanks for your interest.
I have no idea if they are genuine or not.They seem to be triggered by the screen saver cutting in and can only be stopped by re booting.
The details are."Defense + is learning followed by System 32 / Rundll 32 exe followed by all the various software that is installed on my computer.
I let it run for an hour by which time i was getting very annoyed so i rebooted which stopped the popups.
This is nothing new i have experienced it many times before but it has always stopped after 10-15 minutes.
This time however it didn’t stop so i rebooted.
I am beginning to loose patience with CIS there is always a problem one way or another.
I had hoped that the latest version would have sorted out these problems but no there seems to be more interest in adding more bells and whistles rather than clear the remaining problems.

Just disable the “Display balloon messages” on the system tray icon, that will “remove” these “learning” messages.

Thanks Ronny
I quite like having Balloon Messages enabled.
Is there any other way of stooping the Defense + learning messages


I have it enabled also, but one of the dev’s stated somewhere it was not working as they would like and they advise to disable it… so it’s known “buggie” behavior i guess…

Now all is revealed.
Thanks Ronny

Hey Rambo, you could try this and see if it helps (credit goes to Quill for this btw)

This is only for Win 7 RC…

Go to Control Panel->Administrative Tools->Computer Management->Now drop down "Task scheduler, Task schedular library, Microsoft, Windows->Click on “Application Experience”->At the top under name you should see AitAgent and ProgramDataUpdater, right click on ProgramDataUpdater and select “Disable”

Try it and let us know if it helps.


Thanks Matty for your suggestion.
I will certainly give it a try next Week and will report back ASAP

Disabled “display balloon messages” = No “learning” popups from Defense +
That is great
Thanks a million.