Defense+ suddenly blocking Control Panel etc

I’m using version 5.5.195786.1383 and the Defense+ has suddenly gone mad.

It now keeps asking whether to block programs and windows services which it was happy to allow to run before.

It is also stopping me from opening Control Panel and other important parts of Windows - when I try to open them I just get an RPC server not available error box. When I disable Denense+ I can then open Control Panel OK so it is definitely the fault of Defense+.

Assuming that Defense+ has got its rules/configuration in a mess, how can I reset it so that it will stop blocking all of this important stuff?

If I were you, I’d first check that my PC is clean running several AV tools such as Malwarebytes for instance.

If the PC is clean, I’d take the opportunity to remove version 5.5 and installed the last one, 5.10.228257.2253.

PC is clean of viruses.

I uninstalled and downloaded the current version and installed that. It wasn’t great that the default for the new versions seems to be for it to install additional third-party stuff including something about Geeks support that would allow them to access my PC to fix problems. I only noticed these when I spotted the configure install link on the installer dialog box. I unticked both items so only the firewall was ticked, but after the installation was complete I still got a dialog saying that I had an account with the Geek support thing! I really don’t like all this extra stuff being installed by default.

It also now seems to pop up occasional adverts for Comodo’s Android scanning software.

Since installing the new version I have had a fatal page fault error while Vista was booting - fortunately it booted OK the second time. I’ve also had a Windows has recovered from a “bluescreen” fault message box. This is on a system where I have never had any OS crashes or blue-screen messages before.

Then last night my PC would not connect to the internet. The wireless network icon was just displaying “local access only”. I tried manually disconnecting and reconnecting several times, rebooting my PC 3 times and also rebooting the ADSL wireless modem. But it still remained “local access only” and internet access was impossible. Throughout all this my smartphone was able to use the wireless network to access the internet without a hitch - so the problem was something to do with my PC. Then I tried UNinstalling the new Comodo software from my PC and rebooted - BINGO, internet access was back!

I have used Comodo’s firewall for the last few years without much of a problem (apart from it occasionally forgetting apps which I had previously granted access for), but something appears to have gone seriously wrong with their software lately.

I’ve never had any instability problems with my PC until I installed the new version, so I’ve had no alternative but to dump Comodo. I’m now temporarily using the Windows default firewall and all is well. I still have to decide what alternative firewall I am going to use in future - but it will not be Comodo.

Sorry to hear things are not going quite smooth.

For the problem not being able to connect to the web No network connection after using Stealth Ports Wizard (DHCP Broken) may bring a solution in case you want to give CIS another chance.

About the blue screen. Can you download BlueScreenView from Nirsoft and look at the report from the blue screen? Does it give a file Windows thinks is causing the problem?

Here’s a bit more info I just discovered. For the past year or so it has been impossible to print from just one of the user accounts on my PC. When I tried to print it would just pop up an RPC error message box. I spent ages trawling the net to see if there was a fix for it, without success. So I’ve always had to log off and log in as another user to print. I have just noticed that since removing Comodo from the PC, printing now works OK. So in addition to the problems with the new version, I guess Comodo was also the cause of the printing problem too.

Anyway, thanks for the link about the Stealth Ports Wizard causing internet access to fail. However I had not done any configuration of the new version at all since I installed it - it just decided to go “local only” all by itself.

Re bluescreen. There was not an actual blue screen - what happened was a windows dialog box popped up saying that Windows had recovered from a “bluescreen”. Sorry but I can’t remember the exact wording, and I think there may have been a more-info button but I really can’t remember, and I have not encountered this again. I assume that this was a clever new bit of fatal exception handling by Microsoft that manages to avoid some blue screen events from crashing the OS completely.

As I no longer have Comodo installed, I don’t think I’ll be able to provide the info you asked for.

If you ever want to give CIS another chance then we are here to help.