Defense+ Run on demand scan won't run [RESOLVED]

I am running CFW v3.0.18.309 on a new laptop with MS Vista installed.
I am the sole user and "administrator.
When I try to run Defense+ “Scan”, CFW gives me the following message:
" Could not start scanning. Please run the scanner as an administrator. "
I am the admin!

Why is it giving me a problem and how do I fix it?


Probably will need to turn off UAC to make it work. Reported by many of the Vista users as a problem. You could also try checking “run as administrator” on the shortcut, and turning of and on, but seems to not work as often. Bug to be fixed in later version.

I have tried your UAC suggestion with no success. It still gives me the message “run as an admin”. (which I am).
The scan function has a link on the Defense+ page but no shortcut to right click on. So I acnnot try your second suggestion.

Any other suggestions how I can get system scan to run?


Another thing to check is in program files/comodo/firewall/scanners that all 6 .cav files are present. There have been reports of only partial installations. If any are missing, there are copies in the repair folder that you can copy over. The suggestion on “run as admin” was meant for cpf.exe, the whole program. Seems to be a common problem, but not always for the same reasons. :frowning:

I checked program files/comodo/firewall/scanners that all 6 .cav files are present. There were none there. I copied from repair folder and now the Scan functions fine.
Are there any more misfires like this that I should be aware of? A link maybe?
If not for your suggestion, I would never have figure that one out.

This is one of the current bug reports, but don’t know what the fix schedule is. Happens to only a few users, and not always the same problem. Glad it worked for you. :slight_smile: I will mark this thread resolved in case others are looking for a solution.