Defense+ now refuses to allow Thuderbird to run [resolved]


I am running Comodo for Vista (version and have been for several months now. Just yesterday, my wife tried to run her Thuderbird Mail application, and is now presented with a screen saying : “Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access them.”

This has not been a problem with Thunderbird (or any other app) ever. I have had to disable Defense+ in order to get my wife’s Thunderbird working correctly.

I have tried to add Thunderbird.exe to “My Own Safe Files” (several times), but to no avail. Comodo simply will not allow it to execute. What have I done wrong? I’m confused…

I use Thunderbird and haven’t been having any problems D+ is set to custom with all access rights set to ask. Firewall is custom with allow IP out any, any any above the predefined email client rules.

Hello, Welcome to the forums :slight_smile:
Please do this for me, Comodo → Defense+ → Advanced → computer security policy.
Now look for Thunderbrid and edit, Set as trusted application (See screen shot)

This can also be done for the firewall,
Comodo → Firewall → Advanced → Network Security Policy

Hope this helps (:HUG)

[attachment deleted by admin]

Good day,

You may have inadvertantly blocked windows explorer from running Thunderbird,lets find out!

From the main interface click on “Defence+” then “Advanced”.Now click on “Computer Security Policy” where you will find the Defence+ rules which are established.
Look for the entry “%windir%\explorer.exe” and highlight it.Now click on “Edit”.In the new window you need to click on “Access Rights” and then at the top click on “Modify” next to “Run an executable”.
Now you will have an Allowed and Blocked applications window,have a look in the Blocked section to see if Thunderbird is there,if it is highlight it and click “Remove” now APPLY to close all windows.



Helpful solutions all. Thanks for the replies. Thunderbird is now “unblocked” with the Defense+ in clean mode. I believe the problem was due to a defective user (insert sheepish grin here), though I might argue the interface is a little confusing. Here’s what I was doing:

In “My Pending Files” I found the Mozilla Thunderbird executable. I clicked on “Lookup…” and waited until Comodo popped up a message telling me the application was safe. I clicked “Close” on the same dialog, and was then shown another popup box that had the message: “The safe files have been moved to your local Comodo certified files database,” after which the “Pending Programs” started loading again. I thought this meant it was added to the “My Own Safe Files” list, but this isn’t the case. After thinking about it last night, I figured I still had to let the Pending Files list re-load (there are 8,000 of them for some reason – what a pain in the rear waiting for it to load multiple times), then find Thunderbird in the list, then click the “Move” button to move it to my safe files.

After that, Thunderbird worked like a charm. The solutions given also look like they would have worked just fine.

Now, I would argue that it would be more convenient if, after a pending file is scanned and deemed safe, Comodo would simply prompt with “Add to ‘My Safe Files’ list?” (yes/no buttons on the dialog, obviously). But I quibble.

For me, this whole episode brings up another question: How did Thunderbird get denied in the first place? The same version has been installed and in daily use for a good six months. The rest of the family swears they didn’t alter the settings, and I rarely use Windows. My wife’s response to any Comodo pop-up is to immediately click “Block this action” without really looking at the question. Would hitting “Block this action?” on a Comodo popup remove Thunderbird from the list of applications allowed to run?

Thanks for the help and insights.


oh, so my minions have solved your problem >:-D
good work slave >:-D
then i’ll just lock this thread, PM any online slave moderator if you want to reopen it.
welcome to the forum DPowell :Beer