Defense+ not so cooperative

I seem to have an issue with Defense+ not doing what I want to do…
I’ve a memory manager active (Memboost.exe) and Defense + is flooding the log with messages that memboost is accessing the memory of (usually) cfp.exe.

Well, I know that and I regard it as acceptable so I don’t want anymore message about it.
But if I change CIS’s settings of memboost.exe the messages keep coming. If I want to change something about the settings of cfp.exe (in order to allow memboost.exe to access its memory) I get a window telling me "You need to use “My File Groups” window to edit this item. In that specific window I don’t see any suitable option to change.

The interface is still a bowl of spaghetti with regard to certain aspects.

Does someone know how to get rid of the log messages of this specific program (so I still want to see messages of other programs). I know it is possible because in CIS v3 I could get rid of the messages but I can’t get it to work anymore.


This means that this application belongs to a group and can not modify individually this settings.
What is the group belonging to this application?


[attachment deleted by admin]

Thanks Ovidiu for your reaction.
I described the “problem” in the original post:

I’ve a memory manager active (Memboost.exe) and Defense + is flooding the log with messages that memboost is accessing the memory of (usually) cfp.exe.

So, I don’t want to see any log messages about memboost.exe accessing the memory of cfp.exe.
In my opinion it’s quite normal for a memory manager to access memory :a0
so I don’t need log messages about it.

I know I can solve that problem by changing the settings of one of the two programs involved, but I still can’t find it.

Concerning your inquiry:
cfp.exe belongs to the group of Comodo Internet Security and memboost.exe doesn’t belong to a specific group.

To get rid of the log entries you need to tell D+ to allow the memory manager to be able access the Comodo Internet Security executables.

Here is the way to go. Go to Defense + → Advanced → Computer Security Policy → look up Comodo Internet Security → select it.

Then choose Edit → Protection Settings → push the Modify button behind Interprocess Memory Access → Add → now choose how to add your memory manager to the exceptions -->then Apply and Ok your way back to the main screen.

Then check again.

See the attached image for reference.

[attachment deleted by admin]

EricJH, thanks man! That did the trick. No more log entry about the memory manager.

B.T.W.: I discovered that CIS does not recognize it as a “running process”, although in fact it is definitely running. Apparently CIS thinks it is a “running process” when it does something and not when it’s just waiting or so.

That’s a known bug that it won’t show all running processes.