Defense+ 'not functioning properly'

I have been running comodo for over a year now, on advice from major geeks… all has been fine until recently. Presently have a message ‘the defense+ is not functioning properly!’ when i click the run diagnostic button under it, it says ‘the diagnostics utility did not find any problems with your installation’. Running in ‘safe’ mode. Not sure how this started. Can someone advise on how to find out what’s going on? Thanks in advance.

Did you recently make changes to your system? Did you install new programs?

When I first used the latest 2012 version of Comodo Firewalll, I too received the same app warning and “no problems” troubleshooter advice…that’s how I got to this topic.

I’d installed (just) Firewall to a Windows 7 Home Premium 64 bit, and as installer offered to browse to any file destination I selected removable media (works fine with IceDragon, for example, on 64 bit OS/PC). All worked fine but I couldn’t get rid of the warning.

I clean-uninstalled, rebooted, re-installed to “C:” PC hard disk, rebooted, and immediately all was “green check mark”.

P.S.: Checking a review of Firewall at CNET for possible help, I only found a sour comment that Comodo Firewall locks up Windows or crashes it; I’ve been able to configure my network security in Firewall to protect all files regardless of disk, plus all the other good options “normal” users can make; I find I have outstanding penetration security even if I have to keep “Defense+” general settings no higher than “Clean PC” mode; going higher than that DID make my OS lock up, but at “Clean PC” I’ve been testing at high penetration resistance, with literal set-and-forget ease…I mention in case anyone else sees that or similar review en route to solving “not functioning properly” issue, like I did.

Installing on a removable medium was likely the cause of your problems. I have never tried it but I would advice against it. The reason is that CIS will not trust files on “mounted devices” like f.e. your USB (flash) drive.