Defense+ (not functioning properly) and Virus (0x80004002) not working.


I am having many problems with Comodo at the moment. After having purchased BitDefender 2010, and starting to feel less secure, little support, and constantly not working. I decided to come back to Comodo (Was using it before I went to another provider - wish I never did now; let alone paid for the service!)

Comodo reports in the Summary section “System Status: The Defense+ is not functioning properly! Please run the diagnostics utility to fix the problem”. Running the diagnostics reveals no problems can be detected.

Comodo states that the Virus Defense has never been updated, which to preform a scan of all drives (14 drives in total, including disk and optical), so of course I want to update it to ensure nothing is here at the moment - bitdefender couldn’t even start doing virus scans as it was ALWAYS preforming a scan and couldn’t intalise (spelling).

“Update failed. Error code 0x80004002. No such interface supported.” The same error message appears when trying to preform an actual virus scan.

In order to try to fix this problem myself I have used Revo Uninstaller (in advanced mode) and scanned for left over information. Deleted all this twice, each time the same issuses are still there even after repeated restarts after each stage.

Somewhere in the forums I found a Moderator script file to scan my computer, in which I have run and hopefully correctly attached the output file. However I just noticed the time and am running late for work, I hope this works as I don’t have time to currently correct any mistakes I may have placed.

Any help to solve these two problems most welcome. (I will also soon after work contact live help if I can’t find a solution).

Thanks all.

[attachment deleted by admin]

Please explain “each time the same issuses are still there”

Do you mean that Defense+ is still not working properly ?

Or do you mean that RevoUninstaller finds things to delete,
and you tell it to delete them,
and then you reboot and run RevoUninstaller again,
and it finds exactly the same items to delete ?

If it is the latter then the problem is neither Comodo nor RevoUninstaller,
but Windows and its permissions.

It is possible that you could find a tool that automatically identified and got rid of these problems,
but an automatic search and destroy that overcomes all Windows security restrictions is NOT something I would unleash.
Far better to manually identify and target those things that Windows wants to preserve.

You can use Regedit to take ownership of and then delete any keys that have embedded themselves,
but I find it easier to use Registrar Registry Manager 6.50 from
Resplendence Software - Free Downloads.
N.B. I always ensure I have a full compete and up-to-date registry backup by ERUNT before I meddle with the registry.

Using CACLS under DOS you can take ownership of and remove any files and folders that have embedded themselves.


Comodo has the problems still there after reinstall. To my knowledge (which isn’t great), I’m unable to use RevoUninstaller once it removes a program, so cannot “retest” if files/registry items are left once it has closed the window to preform the programs uninstall.

I will uninstall comodo again (sigh) and use Revo and then the Registry Manager. I’ll post when that is completed.

You don’t want to uninstall, then use Revo. Use Revo to uninstall.

Revo will start the applications uninstaller. After it completes, it will want you to restart your system. Select No, so Revo can continue looking for leftovers from the CIS uninstaller.

That’s what I done :). I use it to uninstall, asked to restart (no), scan registry and files, delete, restart.

I then reinstall… same problem still present.

Going to install now after Using Revo, then Comodo System Cleaner - since I didn’t understand what to do with the Registry Manager.

Post details in a few.

I decided I would redownload the installer. This is quite annoying. Thou thats not me blamming anyone, just me venting; nicely for a chance :)[/edit]

Okay, I’ve done that.

Uninstalled with Revo, used the Cleanup tool, restarted.
Used the Cleanup tool (Failed to find any entries), reinstalled, restarted.

Comodo loads up and same issuses, different installer as well.

I did notice however, that I have XP SP3, and the installer says XP SP2… can this be the problem?

You are using the latest version of CIS 3.13.blabla.581?

What other security programs are running in the background? Try disabling them. Does that help or not.

When it doesn’t help try the following:
We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer.

When the problem persists make sure there are no auto starts from your previous security programs. Download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting go to Options and choose to hide Windows and Microsoft entries, to include empty locations and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

None of the above matters now. I formated my pc, reinstalled windows and the same errors are there!!! :-TD :-TD

To answer your questions thou Eric, none. Other than bitdefender; that was uninstalled, that’s all I used. Now after formating my pc, I still have “defense+” and virus error.

So I’m fully puzzled by the problem. This is a formated pc hard drive, reinstall of windows… so I don’t have a clue to what is causing it.

In my personal view, it removes it from what I (or on my behave; windows) has done, and is in the hands of Comodo… perhaps with hardware?

After all that time, all it was, was a corrupted installer! Stupid internet!

Thanks guys at the forum, thanks Lilly @ Comodo Live Support! You all rock!

This problem has now been fixed thanks to a re-download of the same file. PEACE