Defense+ Not Functioning Correctly [SOLVED]

can anyone else help me further? im still stuck with this problem

One way to double check conflicting or old drivers is to go to Device Manager and open the Non-Plug and Play Drivers (in the View menu, enable Show hidden devices). Then you can screenshot it.

here you go

[attachment deleted by admin]

You changed security programs since then. It seems that antilog32 is from Zemana AntiLogger and avgio, ssmdrv & avipbb are Avira Antivir drivers. I know Avira is compatible.

I’ll test CIS in safe mode and report back on whether it’s possible to load it properly, which if it does it can at least prove there’s a driver conflict.

Result: nope. But I don’t know if reinstalling in safe mode might work.

Make sure of the following:
-download it from the official site: Firewall Download | Best Firewall Security software for Windows
-don’t install Comodo Antivirus if you use another antivirus
-when installing, try to close as many other non-Operating System related software as possible

I read that someone with the same error had reformatted their PC and even that didn’t work. It was later discovered to be a corrupted installer. We can look at others’ cases on this issue:
https://forums.comodo.com/empty-t30418.0.html
https://forums.comodo.com/empty-t33709.0.html
https://forums.comodo.com/empty-t42522.0.html
https://forums.comodo.com/empty-t29571.0.html
https://forums.comodo.com/empty-t50640.0.html

There were many other related threads, but I didn’t list them because they were inconclusive.

I redownloaded the setup file and even checked the bytes and everything matched up so its not a corrupt issue. Also when i reinstalled Comodo, i uninstalled all of my security programs and closed as much as I could but the problem still persists. If it helps any, I had a similar scenario to someone else who had the same problem as me where I installed windows xp sp2 and upgraded to sp3 through windows updates. His solution didnt work for me though

I can’t see anything conflicting based on the info you provided so far. At this point, it seems like it’s related to system files/registry, so I’m out of ideas unless you have a full back up or better yet, an imaging program to prepare a reformat as a test. But we all know how long that can take :-\

Im happy to announce that it must have been an issue with service pack 3. I just reformatted and installed service pack 3 through windows updates before installing comodo and everything is fine.

Excellent and congrats :slight_smile: