Defense+ Not Functioning Correctly [SOLVED]

My system is running Windows XP Service Pack 3. A day after installing comodo, defense+ gave em this message. I tried to run diagnostics, but it said there was no errors. I uninstalled and ran the clean-up tool (did this twice) but I’m still getting the same error. Any possible solutions?

Are you running as Limited User or admin?

Try disabling all other security software that is running in the background and see if that helps. Did you install a program after you installed CIS?

I’m running as Admin. The my antivirus and antimalware do not seem to affect it. I’ve only installed some updates from windows since installing comodo.

Try running Diagnositcs under Miscellaneous and let us know what it reports and if it can fix the problem or not.

nope tried that and said there were no problems

Try to switch to proactive mode. Start GUI > Miscellaneous > Manage my Configurations. If you already are in proactive mode, switch to another one, as long as it is one of Comodo’s default rather than an imported or modified one.


switching didnt work either

What AV and antimalware programs are you using? Did disable them for testing?

Do you have other programs that interfer with networking like Netlimiter or others? Try temporary disabling them.

I am running avast antivirus and malwarebytes. I tried disabling them but no luck

I’d like to add that I have installed Comodo with Avast and malwarebytes on my sister’s computer who is also running windows xp, and she has no problems. I have also just recently reformatted my computer so it can’t be a matter of a system error.

Also, I have disabled a lot of services that I found unnecessary before I installed Comodo. That could be a probable explanation for my problem. Can anyone tell me what windows services Comodo relies upon?

It seems like I had the same services running except Remote Access Connection Manger and telphony. I started them and reinstalled Comodo again, but it’s still giving me the same problem.

Remote Access Connection Manger and Telephony is only if you have DSL or dial-up internet, otherwise you should disable them.

You mentioned you had an antivirus and antimalware. Did you install Comodo Antivirus as well? This error usually means a driver conflict. If you want to test it out, try uninstalling the others, then install CIS first to see if the issue remains.

Ok So i uninstalled those programs and reinstalled comodo and the same problem persists.

Does this error come up immediately on each boot up ? Any other major software/utilities that loads up?

I don’t have any other major software. This error shows up immediately, even after a clean install.

Anything relevant in the Event Viewer’s Application and System (start → run → eventvwr)?

I couldn’t see anything comodo-related, but maybe I missed something. So i attached the log files for you. Hopefully you can pinpoint my problem

[attachment deleted by admin]

From the Applications log, it seems some repository files may be corrupt, but this isn’t too big of a deal since it only affects the Security Center. If you wish to pursue a possible rebuild of the repository folder, check this (should apply to XP SP3 as well).

From the System log, I found this line:

1/17/2010	10:58:34 AM	Service Control Manager	Error	None	7034	N/A	DC5-DA13FD90FA4	The COMODO Internet Security Helper Service service terminated unexpectedly.  It has done this 1 time(s).

It shows that yesterday morning your CIS was shut down 4 minutes and 17 seconds after your computer booted up and started the Event Log service. There was another instance of this, but it’s basically the same chain of events without anything obvious. Such a log entry to me means cmdagent.exe was in the process of (trying) loading or something like that. That CIS Help Service is cmdagent.exe. Based on the timing and the fact that other services like the Avast mail scanner was sent stop control, I assume it was because you rebooted the computer. Speaking of Avast, I thought you had disabled and then uninstalled it to test, but why was it present in the log? Also, even though I can guess, I want to know the answer to my previous question:


The Computer Browser service depends on the Server service which failed to start because of the following error: 
The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. 

→ If you’re not networked to other PC’s, disable the Computer Browser and Server services for extra security / slightly faster boot time. There’re other errors I see, but that’s going too far out of scope.

You also have many of these disk-related / paging errors, which I don’t know if has any relevance:

Disk	Warning	None	51	N/A	DC5-DA13FD90FA4	An error was detected on device \Device\Harddisk1\D during a paging operation.

Well, I rebuilt the windows repository, again with no luck. I did not install comodo antivirus. I think the reason why avast showed up was because I reinstalled it after confirming it was not the problem. Meanwhile, I disabled defense+ and it still shows the error. That might mean something, or nothing. I dont know