Defense Losing its Mind??

I was curious if anyone else has seen this problem.

I am running Comodo Internet Security 4.1.150349.920 which I have been running for several months.

Previously I had the problem with not being able to download and install updates, but got that fixed with a de-install, fresh program download, and program install. Now everything seems to be A-OK.

However, even though I have been running this program for months now, Defense seems to be experiencing Alzheimers as of two days ago. Every program that I run, even though I run them all the time (including Word and the like) are pausing while Defense alerts on them multiple times per program.

I am having to click on the “Go ahead, it’s okay” button multiple times to get Defense to finally permit the program to run.

But like I said, I ran Word the day before this started (and every day before that) and no such alerts. (The program had stopped alerting on Word after the first couple of times following the new install.)

So, has anyone seen this? So far today I have activated four programs that I use all the time and Defense alerted on three of them (it has stopped alerting on Word as of today – finally). :-\

Oh, and I haven’t changed a thing on CIS or Defense, and up until this morning I had not even updated the anti-virus and such in a week or so. (Bad me.)


sounds like a corrupted trusted list. open CIS, go to misc at the top, run diagnostics, it should find a problem, reboot when it is done. that should fix it.

I am seeing the same problem as chicklit every day. I have the same version of CIS, my PC is running Win7 X64, no other security apps, and I use Clean PC Mode with the sandbox disabled.

I notice that D+ works fine for several hours after boot-up. I suspect what happens is that D+ loses its mind after an AV database update. After I get a D+ pop-up (telling me D+ is out to lunch), I reboot and D+ is fine again.

This is really frustrating. I have two PCs running WinXP that remain on CIS v3.14 because of this bug. On my Win7 X64 PC, the options I am aware of are to disable D+ or uninstall CIS.

Here is another thread that sounds like the same problem:

Hi there. Thanks for the response, languy99.

Tried running diagnostics as suggested. The response was that there was nothing wrong.

I haven’t noticed this problem, I don’t believe, on Internet programs. These are pretty much programs that are resident on my hard drive, like Word, some of my games, etc. And the programs are already installed and have been running with no problems.

Eventually Defense stops erroring on them, but it is frustrating because I have already been through this once just after the Comodo installation. And I’m wondering if, in some undetermined time in the future, the program will begin questioning programs that have previously been determined to be safe.

Any other suggestions? ???

Can you look under Defense + -->Advanced → Computer Security Policy and see if there are rules for the programs you get alerted for?

explorer.exe is treated as Trusted Application, which remains the same as the initial Proactive Security configuration. The other programs have no rules. Under Defense+ Settings, I have “Create rules for safe applications” unchecked.

I seems that D+ suddenly treats many programs as unsafe even though they are already on the disk with D+ in Clean PC mode. Is it time to report this as a bug?

I have seen CIS loose rules when cfp.exe crashed. Nest thing to do is use system restore to go back to a previous state of the OS. This works because CIS stores its rules in the registry.

This is maybe guessing, but when this happens have a look at Services in Msconfig and see if Comodo Internet Security Helper Service is running. If not a reboot probably restarts it.

Since rebooting resolves the problem temporarily, this sounds like a different problem than what EricJH describes.

Next time I keep my PC running long enough to see the problem (about 5 hours), I will take the suggestions to check if the CIS helper service and processes are running.

I have a similar problem, and it happens only with one app, and it happens everytime, even after a reboot. As soon as I start the app, there’s a series of six or seven alerts, and even though I’ve clicked the remember my answer option several times, it still asks this question.

Once I had shifted the app to another folder, and I thought maybe it’ll ask for now, but not later, but it happens everytime even if it has been in the same folder for a week. Shouldn’t CIS save some sort of md5 hash or whatever so that it knows its the same program?

Do you have sandbox enabled? Is the file in question on a “mounted device” like external HD, USB stick, encrypted partition?

Once I had shifted the app to another folder, and I thought maybe it'll ask for now, but not later, but it happens everytime even if it has been in the same folder for a week. Shouldn't CIS save some sort of md5 hash or whatever so that it knows its the same program?
Moving a file and not getting alerted when the application starts from the new folder is an error with v4 that will be fixed. Not sure if it has been fixed in the v5 beta though. Hash checks are added in v5 (SHA2 256 if I recall correctly).

I don’t have sandbox enabled. The first time I ran it, it sandboxed Bitdefender. This was the time when the sandbox was released, and I decided it would be better to use it after the errors or whatever were corrected in later releases, but I haven’t got down to using it yet.

The program is not on a mounted device either. Its a little app, a duplicate image finder, and while a whole lot of people have downloaded and used it without any problems, and recommend it, and I have scanned it with two different AVs, I still don’t want to add it as a trusted program.

As an earlier poster on this thread recommended, I ran a diagnostic check, but it said everything is fine.

btw, while in my first post I had said CIS gives alerts every time, it actually gives alerts most of the time, even if run from the same folder. Sorry about that, was in a hurry. I started the app right now, and it started up silently, but yesterday it had given alerts. Maybe CIS is reading what I type…