Defense+ locking my system when trying to start games, CIS 4.1.150349.920

I have CIS 4.1.150349.920 installed on Windows 7 Ulitmate 32 bit.

Before that I was using Avast! and PCTools firewall (to test them out)

Once installed CIS 4.1.150349.920, I had problems when launching games. At the point where Defense+ would popup a message and I would normally Alt+Tab to the message and allow the action or set the program as trusted etc.

Instead, the screen goes blank, and keyboard\mouse won’t respond to input.

If I set Defense+ level to Disabled, there are no problems.

I have never had this issue before, on XP, Vista or Windows 7, but I was also running older versions of CIS then, too.

I am still getting this problem and it’s really annoying.

Can someone please help?

The problem is caused because you get a D+ alert but the full screen is blocking view. When you know your system is free from malware try the following:

Notice that the brand new v5 has a Game Mode.

I think you may be getting this confused with the problem I usually had.

What used to happen:
If the popup appeared behind a full-screen game, sometimes the game could not minimise (for whatever reason), and I could not allow the game on the D+ alert.

In this case, all I had to do was press the sleep button and force my PC into standby mode.

Then, I just had to resume from standby, login, and the D+ window would be on top, and I could allow the game, and it would work.

(This method worked 99% of the time) Sometimes I would have to just restart the machine blindly (Press Windows key, then U, then R which will tell windows to restart, requires different key combination in Vista\Win7)

In all cases, Windows would respond and either go into Standby or Restart as I told it to.

What happens now:
Game launches and goes fullscreen, D+ tries to pop up an alert, Windows completely locks up and won’t respond to Standby button or any other method as shown in the other scenario.

Only option is to force a hard reset with the reset button (can’t do soft restart in Windows as it’s locked up)

Did you try temporarily switching to training mode? Or adding the game’s executables to My Own Safe Files? Does the problem persist after having tried these two methods?

Did not try learning mode but if I manually put the game as a trusted application then it works just fine.
It seems only the problem happens when the alert pops up behind the game.

Since this did not happen before I am thinking it’s a bug.

In the new v5 Comodo finally introduced Game Mode.

Over the last couple of months the list of trusted game makers has been increased tremendously. There is a sticky topic in the news/feedback/anouncement board where people can submit games they want to be made trusted The new list and the cloud look up of trusted vendors and white list is but one of the new strong points of v5.

A “Game Mode” is a nice idea but that is not the point.

I do not want anything to automatically allow any program. I only wish to only allow programs I choose, and customize their access. I may want the program to run but not be able to go on the internet. Or, I may want that it does not add a startup entry for some ‘registration reminder’ program every time I run it.

That is why I use Comodo, it gives me full control over what a program can and can’t access.

The only things I automatically allow are Windows updates and that’s about it.

And, as I said before, there used to be no problem, only recently have I experienced the system lockup problem, which is the issue here.

Try adding the game where it happens to the Exclusions of Image Execution Settings (Defense + → Advanced → Defense + Settings).

Do the D+ logs give us a clue about what is happening? Can you post a screenshot of them?

It happens in pretty much all games, as long as Comodo tries to pop up an alert after they go full screen.

I don’t think the problem is that Defense+ is working, it’s the fact that the popup comes while the game is full screen. It’s like some kind of incompatibility with the fact that the game is full screen or something.

Any popups which come BEFORE the game goes fullscreen DON’T cause the lockup problem.

Upgraded to CIS 5.0.162636.1135 and still the problem is here.

Where do I find the logs?

I just replied to another post of you. In that post you are talking about problems with a game installed on a network. Are your games on a fixed drive or on some sort external drive?

The logs are in Defense + → View Defense + Events.

It happens with games both on local and network shares.

However it’s worse on a network share because the settings are not saved. If they were saved, I could eventually get them how I wanted them resulting in no more popups and thus no more crashes.

However, since it doesn’t remember the settings, it always pops up and always crashes when running games on a network drive.

I have just upgraded my video card drivers in the hope that perhaps they were causing the problem somehow (as it seems only related to full screen games + a popup window)

With the games on the network drive you are out of luck.

You could consider updating to v5 and use Game Mode. Or when sticking to v4 put D+ in training mode when you run a game. Then either run the whole time you are playing a game in Training Mode or stop the game after a couple of minutes and put D+ back where it was (CIS will remember until you reboot).

I have the same problem, BUT if i manually add an entry for the game.exe and allow the access to the

Interproces Memory Accesses = no freezeing , game working fine.

But if i leave it deafult (ask) Interproces Memory Accesses = freezing my pc , hard reset necessary.

I seems there is an bug whit programs that are trying to access the memory. This has never happenend
in v3.14.

The same thing happened whit Rapidshare Manager. The weird thing was there was no pop up asking for the memory access.

Deafult (ask) Interproces Memory Accesses = freezing my pc , hard reset necessary.

Manually allowing access to Interproces Memory Accesses = no freezeing

Defens+ - Safe Mod
Sandbox - disabled

Interesting, another person with a similar problem…

As I said before I tried updating to CIS v5 but that did not help.

And as I also said before I don’t want anything to have rules automatically created for it. That is the reason is use Comodo, so I can personally choose what I want, not what anyone else wants.

Clearly this IS some kind of bug or problem, as this other person also is having the same issue, and as I said before, this never used to happen before.

Interestingly I have also noticed something else, it does not seem to fully lock the computer.

Today I was also playing music in the background, and the music kept playing even though the keyboard wouldn’t respond and the monitors were blank.

Does the following FAQ bring any solace to your problem?

I don’t see what could help me from this faq.

I don’t use Sandbox, and Rapidshare Manager Or The Witcher they don’t need greater permissions that those
held by trusted files.

I tested it on another game Dragon Age: Origins , and the same thing happened.

Interprocess memory Access - aks = frezze

Interprocess memory Access - allow = no freezing

This is something that never happened in the v3.14

I really think you should investigate this a little bit.


When your game freezes, does the audio keep playing OK as mine does?
Or does the sound stop or loop?

There is no sound.

This is interesting. I have just found out that this problem doesn’t happen on XP, but it happens on Windows 7.