Defense+ keeps asking to set "Computer Security Policy" rule for Altiris SVS app

I’m running some apps that are virtualized by Altiris SVS and am hitting a problem where if I switch to Paranoid mode, the app that I try to run will repeatedly cause Comodo Defense+ to ask me to allow the permission for whatever the app is trying to do, i.e. Access Memory, Disk, etc…

I would have expected that as long as I select the “Remember my answer”, it should never pop up the message again. Unfortunately, it will keep doing it, even when I verify that the rule has already been added for that app (in fact, multiple rule entries will show up if the permission was asked multiple times). I believe this is similar to the problem reported in v2 in this thread Perhaps the file path mangling that Altiris SVS uses to virtualize the apps is related to this problem?

I am still in the process of trying out Altiris, as well as Comodo. I have only tried to virtualize a few apps so far such as, FindAndRunRobot, Autohotkey, Picassa, VLC. Strangely, I managed to get VLC to work without any pop-ups. I am still in the process of determining why VLC is the exception and what steps I did differently when installing VLC into Altiris. However, all the other apps mentioned above seem to suffer from the problem.

I have even tried adding the apps to the Safe List, but it appears not to make a difference. I also found that if I ran in “Safe Mode” for Defense+, if the app requires permission for the rule to “install global hooks” aka Windows/WinEvent hooks, both the app and the hook driver file need to be on the Safe List.

As these two apps, Comodo and Altiris, seem to be really quite exceptional tools for what they do, I really hope that there can be a resolution. Thanks.