Defense+ Is Not Functioning Properly

I have same issue as reported in Message: Defense+ Is Not Functioning Properly

Just installed program and logged in normally following full reboot, no other security programs running
Still get error message “The Defence+ is not functioning properly” If I run Diagnostics, it tells me everything is fine, If I Check for Updates it tells me I am fully updated. Checked and cmdagent.exe and cfp.exe running

Product Version: 5.5.195786.1383
OS: WindowsXP Home SP2

Any ideas on how to fix?

Can you tell us what other security programs you have installed? Which ones do run in the background as an on access scanner or have a service running? Can you see what happens if you disable the on access scanner or background service?

Also check for left overs of previously installed security programs are in the way. Try using removal tools for those programs. Here is a list of removal tools for common av programs: ESET Knowledgebase .

The only other security programs I have are
Comodo SafeSurf - which I disabled from running
Macafee Security Scan - which is disabled from running

Its a virtually clean install of Windows, so very few programs installed :slight_smile:

If cmdagent.exe then CIS is working properly. Then the alert is a false.

What other programs are installed?

ATI Catalyst Manager
Command and Conquor
Comodo GeekBuddy
Comodo SafeSurf
Internet Explorer
MacAfee Security Scan
Micrografx Picture Publisher
Revo UninstallerPro
Windows Media Player

Microsoft .Net Framework
Microsoft Visual C++ 2008 Redistributable

I upgraded to SP3 to see if this helped, but still shows error

plus the usual system drivers

C-Media WDM Audio Driver
Intel 536EP Modem
RealTek AC97 Audio
Via Rhine-Family Ethernet Adapter

NOT installed (in the conventional sense)
Lunascape Browser
Sysinternals Process Explorer

by this I mean they are on a removable external Hard drive, and are not registered with windows - I get same issues if I have drive connected or disconnected

If you have the time and energy please consider filing a bug report in the Bug Reports - CIS board following the format as described in FORMAT & GUIDE - just COPY/PASTE it!.

I have the same problem, but I created another thread:;new#new.

I did submit bug report, as it looks like there is a fault. Under Defense+ it thinks there is just one process running under Active Process List!!

In my experience having cmdagent.exe running is NOT a sign that the message is a false alert.

If I open the view active processes list it only displays 1 ‘process’, which is clearly not accurate :slight_smile:

in fact it fails to identify any processes running as it is stalling at “Windows Operating System”

so cmdagent.exe running is not a sign the program is running correctly.

[attachment deleted by admin]

I split and merged your post from another topic to your topic. Please don’t cross post.

Is cmagent.exe running in task manager or Process Explorer or similar program I will believe that. There could be a relation between cmdagent.exe and not showing up in Active Processes list. If you did not already add that finding to your bug report please do so.

cmdagent.exe is showing as running in Task Manager.

I have updated Bug Report to highlight this.

Thx. :-TU