Defense+ is not functioning properly

I have installed CIS a few days ago and it worked without any problem untill today. When I started my computer I saw this message “Defense+ is not functioning properly”. I ran the diagnostics but it found no error to fix. So, what is the problem, can anybody help me?

Is the problem still happening?

Did you recently install a new security program? When you check under Processes with Task Manager do you see cmdagent.exe running? Let Task Manager show processes of all users.

Over the last 3 days I have gotten this same error on every computer I have Comodo installed on in the house. 2 laptops with Vista Home Premium and 2 desktops with WindowsXP Home. The diagnostics on Vista gave an error message and said I needed to restart the machine to fix the problem, still trying to get the desktops repaired. cmdagent.exe is running in my process list.

It is striking that it is happening on all 4 computers you have in the house. That makes me suspect there is something in common on all four systems.

What other security and network related programs are running on all four computers? Are all four computers using the same version of CIS? What version?

No other security programs, unless you count spybot or spyware blaster. All 4 are using version 4.1.150349.920. The problem seems to go away with a restart, though as to whether or not it will re-occur I can’t answer.

Did the problem reoccur?

whoops, after a couple of days of no replies I stopped watching this. At least for me the problem has re-occurred a couple of times on one of the laptops running Vista Home Premium and once on my desktop running WindowsXP Home. The error message was “the comodo application agent is not running properly”.

I have the same problem(Defense+ is not functioning properly). CIS is the only security software on my PC, and the task manager is showing cmdagent.exe running. I tried to run diagnostics but it says that it didnt find any problem with installation which is actually correct since im using CIS for about a year now, and the problem started 2 days ago.
So how can I fix this problem?

Can you see what happens if you reinstall CIS on one of the computers following the methodology described here:
https://forums.comodo.com/install-setup-configuration-help-cis/how-to-upgrade-from-v3-to-v4-t58620.0.html

Well I’m not sure who you were talking to but I’ll respond :stuck_out_tongue:

I had already done that on the Vista laptop and so far the problem has not seemed to happen again but it’s not my laptop so I can’t say for certain, only that I haven’t been told “something isn’t working right” 88)

The problem has most definitely not re-occurred on my XP desktop but I haven’t done anything to it, it just seems to have stopped on it’s own accord for now.

Hi

I had this same problem. Just started today. When I restarted my computer it went away.

Thanks for the tip.

I uninstalled and installed comodo firewall several times and cannot get defense + to work either. i turned off defense+ permanently ,rebooted and turned it back on. No change. Any other suggestions? This is a fresh install of XP w/sp3.

i got the same problems, too. each time i use daemon to mount a virtual drive and it won’t work if i restart. so i guess it might be connected with some hardwar changes.

Different problem. Add the complete D-Tools installation folder to the Exclusions list of “Detect Shellcode injections (i.e. Buffer overlfow protection)”.

Hello!

I have the typical same problem what mentioned by many others before.

I’ve tried everything, but nothing helps (Checked vitrual emulator (have nothing), uninstalled with Revo, simply rebooted ect, ect…
But nothing changed.

I have only Avast and SuperAntiSpyware as other security programs.

This is the first time when the problem occured, but I cant get rid of it. Any suggestions what should I do? :cry:

If you want to reinstall CIS then in addition to what I suggest here you can also try the suggestion given in the second part of the advice given here if it doesn’t work. If that still doesn’t work then you can try the advice from here.

Of course this problem may not be solved by simply reinstalling CIS. Therefore I have a few questions.

  1. Which antivirus programs have you had installed in the past?
  2. Which version of Windows are you running (SP as well)?
  3. Which version of CIS do you have installed?
  4. Is this the free version of SuperAntiSpyware?