Defense+ Is Not Functioning Properly [Issue Report]

The bug/issue
1. What you did: Installed Comodo on to a clean machine,
2. What actually happened or you actually saw: Get error icon in taskbar, when open program it advises “Defense+ Is Not Functioning Properly Run Diagnostics”
3. What you expected to happen or see: I had no idea when opening program what it would be flagging as an issue, but hoped I might get more information on what the non-function was - maybe an error code.
4. How you tried to fix it & what happened: I run diagnostics and it advises “The Diagnostics Utility did not find any problems with your installation”. I ran windows updates, and updated to SP3. Posted help request in forum, was advised eventually to submit bug report
5. If its an application compatibility problem have you tried the application fixes here?: Not Applicable
6. Details & exact version of any application (execpt CIS) involved with download link: Not Applicable
7. Whether you can make the problem happen again, and if so exact steps to make it happen: It happens every time I run Comodo
8. Any other information (eg your guess regarding the cause, with reasons):
I have uninstalled and done clean re-install - same problem. No changes made to configuration
EDIT: I don’t know if it is significant, but watching the task bar during booting I noticed that initially the comodo icon starts off ‘normal’ and then as windows continues booting, the icon gets the yellow warning icon.

cmdagent.exe is running and visible under Task Manager, but under View Active Process list in Comodo, no processes are listed as running - it stops at “Windows Operating System” on 1st, and only entry.

Files Appended
screenshot of Active Process List from Comodo
screenshot of complete Active Process List from sysinternals
Defense+ log
CIS report

Your set-up
1. CIS version, AV database version & configuration used: Comodo Configuration - Comodo Internet Security Active, version as in About screenshot
2. a) Have you updated (without uninstall) from CIS 3 or 4: No, it is a clean installation
b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: Not Applicable
3. a) Have you imported a config from a previous version of CIS: No, it is a clean installation
b) if so, have U tried a standard config (without losing settings - if not please do)?: Not Applicable
4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No, it is the exact default version, no changes of any sort made
5. Defense+, Sandbox, Firewall & AV security levels: D+= , Sandbox= , Firewall = , AV =
Defense+ Mode - Safe Mode, No options ticked
Sandbox Mode - enabled
Firewall Mode - Enabled
6. OS version, service pack, number of bits, UAC setting, & account type: WindowsXP, SP3, 32 bit, NA in XP, admin account
7. Other security and utility software installed: Comodo SafeSurf - which is disabled from running
Macafee Security Scan - which is disabled from running
8. Virtual machine used (Please do NOT use Virtual box): Not Applicable

[attachment deleted by admin]

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation


updated bug report, hopefully it meets requirements this time :slight_smile:

Thank you for your Issue report.

Moved to verified.

Thank you