Defense+ is blocking a file in all trusted areas

I am trying to create a scheduled .bat file that accesses a .jar file, however, every time I run the .bat, the .jar is being blocked.

The java file is Selenium Server, it is a program used for functional automated tests against a website; because of this the server includes a proxy control in order to control various browsers.

When it blocks the .jar file, it gives the following warning “Selenium-server-standalone-2.15.0.jar could not be recognized and requests unlimited access to your computer,” to which I choose “Always trust this file or package”.

I have also added both the .jar file and the entire folder to the Trusted Applications definition in the Firewall Network Security Policy.

I have added both the .jar file and the entire folder to Trusted Files in the Defense+ area.

I have added both the .jar file and the entire folder to the Trusted Files in the Defense+ Rules in the Computer Security Policy area.

Yet still the .jar file is continually blocked. The strangest thing is, I have the same .jar and .bat file on my laptop also running Comodo and it’s fine. It never complains about the .jar file and runs immediately upon executing the .bat.

I really need to get this working so that I can schedule the .bat file to execute daily at 5:00am. I cannot run from my laptop as it hibernates overnight; and I would prefer to not disable Comodo’s Defense+.

Any suggestions?

Try giving schedule.bat the Installer/Updater policy in Defense + Rules (Defense + → Computer Security Policy).

After you made the policy look in Defense + rules for a rule called “All Applications”. When it is present you will most likely find the rule for schedule.bat at a place somewhere underneath the “All Applications” rule. In that case drag and drop the rule for schedule.bat to a place somewhere above the “All Applications” rule.

Or you could try the new feature in 5.9 that allows you to trust a file by its path instead of its file hash.

Go to Defense+ → Trusted Files, click Add, then Browse Files. Now you can put a checkmark in the box next to Use file names instead of file hashes (not recommended), then add the required files.

I don’t know however, if this will still work on external storage because previously any external media has always been considered untrusted.

Thanks, this seems to work :slight_smile: