Defense+ incompatible w Securom 7 (Firewall only w Defense+ V3.8.65951.477 x32)

subject: Defense+ incompatible w Securom 7 (Firewall only w Defense+ V3.8.65951.477 x32)

tags: Securom, Securom 7, Defense+, CFP 3.8.65951.477 BUG

Hello, I am having a problem with Securom 7 being incompatible with Comodo Firewall Pro with Defense+ V3.8.65951.477 x32. I do not install the Comodo Antivirus. I install only the Comodo Firewall.

I am running Windows XP SP3 with all current security updates, x86 (32 bit). My computer’s CPU is a 64 bit CPU (AMD Athlon 64 x2 6000+). I am using an Administrator account.
I normally use a third party antivirus product, but I have duplicated every aspect of this issue without any antivirus installed.

If I install Comodo Firewall Pro as Firewall only, without Defense+, there is no problem with the program I have which uses Securom 7. But when I install CFP as " Firewall with Optimum Proactive Defense ", the issue occurs. If after installing with Defense+, I set the Defense+ security level to " Disabled ", the issue still occurs. The issue only is resolved by uninstalling the firewall completely, then reinstalling as " Firewall Only ".

My program that uses Securom 7 is the Oxford Spanish Dictionary on CD-ROM, Third edition. The main executable of the program, even when the program is completely installed on the hard drive, contains Securom 7 code. The background Securom 7 security executable, UAService7.exe , is running in the background at all times while the program is installed. The first time the program is executed after installing, it checks for the original CD-ROM. However, I have done this initial check in Safe Mode, and on reboot, with Comodo Firewall Pro with Defense+ installed, the dictionary still does not load properly.

When I try to load the program through either the installed shortcut, or directly by double-clicking the executable file, it shows the wait mouse cursor for just a bit and then no sign that it even tried to load.

I have defined both the dictionary executable – c:\program files\osd\osd.exe – and the background Securom 7 process – c:\windows\system32\UAServer7.exe as trusted applications with the " Define a New Trusted Application " option, and the issue still occurs. I have also tried going into the " Computer Security Policy " from the Defense+ Advanced Tasks, and adding them both as trusted applications. (I’m not sure if this is just doing the same thing, so I tried it just in case it’s not redundant). This does not help the issue either.

I am going to install the Firewall Only without Defense+ as a workaround for the time being, but considering how many different programs utilize Securom 7 protection, I believe the problem I am having is worth your time to resolve.

Thanks in advance for your help,