Defense+ Gone Crazy :S

I have this weird problem in which my Defense+ “Trusted Files” Rules disappears and it keep asking me every time I run a program.

I Can’t open Control Panel as Com Surrogate Popup keeps appearing on Defense+ Sand-boxing.

Tried reinstalling Comodo CIS but no luck.

System Specs:
Windows 7 x64 Ultimate Build 7600 (no SP1)

Please help me out.


I think I may have the same issue.
after one of the recent comodo updates I keep getting notifications for some windows exes
like dllhost.exe (shows COM Surrogate as the description) and
wermgr.exe (Windows Problem Reporting)

it says the files are not digitally signed…
checking the Always Trust does not seem to stick…as the notification keeps popping back up
I’m also running 7 x64 without SP1

I have seen this before on some of my machines. On my machines a restart seems to fix the problem…

If it doesn’t please reply back.


I’ve had to yank this software off several score machines.

None of the owners of said machines are interested in waiting.

well I’ve had the issue where just a restart has fixed it previously
I had already tried that a couple times in this instance as well
either way…seems it may be fixed now. it doesn’t seem to be doing it anymore

For those of you who are still having problem I would like to know what the results of running the diagnostics are?

Thank you.