Defense+ Freezes

I’m a great admirer of Comodo. Been using Firewall for about a year now, and been on CIS since, well, the beta’s.

Really happy with the security and how it works.

Unfortunately, I have encountered a problem: I can’t change my Defense+ mode. If I try to do that, CIS freezes and nothing but a reboot is possible, as it also starts to slowly block my computer.

I don’t have a dump-file or anything, as it doesn’t generate it.
Would be great if this could be resolved, haven’t had this problem in RC2, might have to go back to that… :frowning:

Thanks in advance :slight_smile:

What other Security programs are you running? What’s your OS? Did you uninstall RC2 before installing CIS?


Whoops… knew I forgot something…

Anyhow: Running Vista X64, with CIS 64-bit. No other Security programs running.
Uninstalled RC2 prior to installing Final. First time I uninstalled RC, since I did upgrades before of the RC’s.

Cleared out Registry and Comodo folders (I could find).

Reinstalled it as well, but to no avail. If any other information is necessary, I’ll be happy to provide it.


Hello… Just checking because I have had a problem similiar to this…

Comodo → Defense+ → Advanced → Defense+ Settings.
Make sure that Defense+ Is not deactivated.
Even when Defense+ is deactivated you can still change the mode and sometimes I have found it can freeze.

same here running XP home edition,ad muncher, kcleaner & sandboxie .the whole CIS tends to freeze had to uninstall the antivirus cause of update problems .


Hi, did u checked ur DefencPlus log? Can u post it here? Also when CIS freezes, can u checkk cfp.exe CPU usage?

Also did u protect any application from hooking in Defence Plus rules?

I had a very similar issue here( post no. 85 of thread).

And the cause was this( post no.92)

My Defense+ Logs doesn’t show anything out of the ordinary. De cfp.exe usage when CIS freezes is normal, doesn’t peak or anything.
I haven’t specifically set protection against hooking, at least, that I know of.

Also can’t close CIS when this happens, need to reboot computer to be able to do anything.
crashrep.exe doesn’t do anything either when it hangs.

Will try crashrep.exe after a reboot.

Unfortunately, after updating Defense+ still freezes CIS when trying to change the mode.
The mode is being changed tho, just the GUI crashes somehow…

Could you tell was the UAC enabled during update?

UAC is disabled on my PC, it’s pretty much the first thing I do when installing my PC, as it is more annoying than “protects” me.

The fact is, this problem was fixed after it was reported in one of beta versions.
Now we can not reproduce it on release versions.

Do you use any custom themes for your CIS?
Does the workaround with changing mode via tray icon context menu works?
Does it reproduces every time or time-to-time
Do you use AERO?

Woohoo, I found an old bug :stuck_out_tongue:

Anyway: it’s not that critical, since it does change my setting, just need to reboot after changing it to get “control” over CIS back. All other sliders work fine as well.

I’m not using themes for CIS, changing mode via tray icon works as well, it reproduces every time and I am using AERO.

Further information on my PC: Intel Core2Duo E8400, Radeon HD3870, 4GB RAM, OS running on 2x WD Raptor 74GB in RAID-0.

I’m thinking it could be due to a “dirty” Vista installation. Unfortunately, I currently do not have the time to reinstall Vista. My goal is to reinstall before the end of the year tho :stuck_out_tongue:

I have a similar problem now - except my entire machine freezes on booting, not just CIS! My only solution is to disable Defense+ entirely from Safe Mode and reboot.

My system: Vista 32bit, have tried release & latest Beta version (3.8.61948.459), UAC disabled, no custom themes, cannot get to context menu so no way to change mode, reproducible every time.

I can submit crashrep.exe but since the application never crashes (the whole machine hangs) I am not sure it’ll have any valuable data.

I also have had a similar problem with the “Direct Keyboad Access” since CFP3.0.
Some application programs in Safe Mode,When the Pop-up window show the balloon message with “Direct Keyboad Access”,I can’t push both the OK and Cancel buttons on the Pop-up window and then my computer keeps freezing.
e.g. C:\WINDOWS\system32\calc.exe->click Help Topics,C:\Program Files\Avira\AntiVir PersonalEdition Classic\avnotify.exe->While updating,etc…
It happens every time though I tried to reboot or re-install.

XPSP3 32bit,Defence+ SafeMode Version 3.5.57173.439

Just to clarify, for me this is a total system hang. The mouse doesn’t respond, the keyboard doesn’t respond, HD stops accessing, CD drives spin down…everything’s hung. The only option is to power cycle the machine.

If I launch a full screen application that wasn’t in the list, for example a new game and the Defense+ is on Clean PC, Safe or Paranoid modes - the whole computer just freezes. I can’t do CTRL-ALT-DELETE to get to the task manager and kill the game, because the PC is not responding. I have to reboot by pushing the power button.
If I set D+ on training mode and then launch a full sreen application, everything is fine.

Can you guys reproduce this issue ?


Windows Vista SP1 32bit

What applications are set to isolated or limited application in your D+ rules?

All on Custom, nothing blocks nothing ;D

[attachment deleted by admin]

Same here - given that the entire machine freezes the first time I reboot after activating D+, I haven’t gotten a chance to add any D+ rules :wink:

There are two ways of dealing with games and other full screen apps.

Manually make alll executables and bat files a safe file. Go to Defense + → Common tasks → My own safe files → add → Browse files → navigate to the game apps folders and add.

Putting CIS in safe mode before you play the game. CIS will now make rules while you play.

Does one of the above strategies work?