Defense+ disables IDT High-Definition Audio CODEC Driver auto-start up

Hey guys,

For the longest time I’ve been having to manually reinstall myt laptop’s audio CODEC drivers everytime I turn my laptop on because the laptop’s speakers won’t work otherwise (even though headphones do plugged in the appropriate jack). I never imagined that Comodo CIS would have anything to do with it however I just noticed that whenever I permanently disable Defense+ and then boot, reboot, etc my laptop… The speakers work (like they should) with no intervention from my end.

Of course I tried to enable Defense+ again and it goes back to no-sound-when-fresh-from-boot unless I reinstall the driver during that session. I also tried different combinations of Defense+ settings and nothing works unless Defense+ is permanently disabled.

I was wondering what the audio drivers driver or Defense+ might be doing wrong for this to happen? Also, will Comodo be able to fix it from their end? I said on the last topic I opened that I won’t permanently disable Defense+ just to allow my Windows Live Essentials to work (because Defense+, just like Comodo Memory Firewall, was consistently 'causing the Windows Live Communications Platform to crash.), however having no sound from my laptop speakers is a completely different issue. The inconvenience of having to manually reinstall the drivers on each boot just to get sounds is too great for me to ignore, and including the driver installation files in the list of startup programs will significantly increase boot up time (let’s say, close to 3 minutes, which is how long it takes to reinstall those drivers. LOL!).

I hope this can be addressed. I love Comodo and I do not want to have to either switch to another AV program or keep CIS but with Defense+ permanently disabled.

For your reference, here is the driver I’m referring to:


Additional information:

  • AMD Athlon QL-60 (64 bit capable, but running 32 bit mode 'cause of the OS)
  • Windows Vista Business 32 bit with SP1
  • Comodo CIS, Secure E-Mail, BOClean, and Back-up
  • No sound from speakers out of boot with Defense+ enabled
  • Permanently disabling Defense+ corrects this
  • Default settings, also tried with Comodo Firewall and Defense+ on training mode
  • No BSOD or dump files to post
  • Administrator with UAC enabled

What are you using for a computer? Is this a laptop? HP?
Reason I ask, a similar issue was raised about sound issues on HP laptops. The solution, it turned out, was to update the audio drivers that came with the computer.

Yes, it’s an HP laptop with everything (including audio drivers, system BIOS, CIS, etc) updated to/with their newest version/patch… Still experiencing problems though. :cry:


As far as I can tell you do have the latest codec driver. I did notice on the HP boards others having similar issues and no CIS installed. (Note, I did not go far enough in the thread to verify the driver version they had.)
Would you be willing to try the CIS 3.9 beta to see if this resolves your problem?

I have a no beta-policy for my laptop…

Wait, I just installed Comodo HopSurf which is on beta. LOL! Fine, I’ll reconsider then. I’ll post any updates here. :smiley:

DId you get the latest drivers from the HP web site or from the chip makers’s web site? Drivers on web sites of OEM’s are not always up to date.

I actually realized that and tried it before going to work today; the results - So far so good.

Interestingly, after I updated the audio drivers of my laptop, enabling Defense+ not only no longer prevents the speakers from working from a fresh start-up, but also allows Windows Live Communications Platform to work flawlessly. My Windows Live Essential programs have not crashed even with Defense+ enabled since I updated the audio drivers… I’m not sure how that’s connected but again - So far so good, and I’m happy.

I’ll stress those programs some more and then reboot the laptop a couple more times and see if I still encounter any problem. If I do, I’ll try to install CIS 3.9 Beta then will let you guys know how that works.

I LOVE COMODO. :slight_smile: