Defense+ creates tmp files instead of completely block

A. THE BUG/ISSUE:

  1. What you did:
  2. Added rule for notepad.exe in Defense+ and blocked Protected files and folders in it with checkbox
  3. Run notepad.exe and tried to save txt file in WINDOWS folder
  4. Recieved error for this operation
  5. What actually happened or you actually saw: I looked in the WINDOWS folder and finded TMP*.tmp file there with size 0 bytes and MD5 D41D8CD98F00B204E9800998ECF8427E
  6. What you expected to happen or see: I expected that CIS totally blocked Protected folder from any changes with notepad because I have created rule for this.
  7. How you tried to fix it & what happened: Reinstalled CIS but this didn’t help
  8. If a software compatibility problem have you tried the compatibility fixes (link in format)?: I haven’t compatibility problem
  9. Details & exact version of any software (execpt CIS) involved (with download link unless malware): notepad.exe or any other software which can create files
  10. Whether you can make the problem happen again, and if so precise steps to make it happen: Yes, this problem is easily reproduced with any software if block the creation of new files in Protected folders with Defence+
  11. Any other information (eg your guess regarding the cause, with reasons): No

B. FILES APPENDED. (Please zip unless screenshots).:

  1. Screenshots of the Defense plus Active Processes List (Required for all issues): Appended
  2. Screenshots illustrating the bug: Appended
  3. Screenshots of related CIS event logs: Appended
  4. A CIS config report or file: Appended
  5. Crash or freeze dump file: No crashes or freezes so not appended
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version: Appended

C. YOUR SETUP:

  1. CIS version, AV database version & configuration: CIS version 5.10.228257.2253, database 11826, configuration Internet Security (Firewall, Defense+ and Antivirus default)
  2. a) Have you updated (without uninstall) from a previous version of CIS: No
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: Yes
  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a standard config (without losing settings - if not please do)?: Yes
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): Only make rule for notepad.exe as described above
  5. Defense+, Sandbox, Firewall & AV security levels: All default (D+=Safe, Sandbox=Enabled, Firewall=Safe, AV=Stateful, Heuristics=Low)
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows XP Pro, SP3, 32 bit, No Uac, Admin
  7. Other security and utility software currently installed: None
  8. Other security software previously installed at any time since Windows was last installed: None
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]: No

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

Mouse