Defense+ causes problems with Alcohol 120 [Resolved?]

Hi, first post here.
I have been using Comodo Firewall (now CIS) for 2 years now with minimal problems.
Today I upgraded to the latest version of CIS and I had the following problems:
When I tried to launch Alcohol 120% (latest version) it would give me a message that it couldn’t load the drivers that it needed and it would work with reduced functionality.
When trying to re-install Alcohol the setup program would fail to start the installation and would report an internal error.

In the end I saw that these problems would go away when I permanently disabled Defense+.
Another seemingly unrelated problem also disappeared. The game Crysis would crash when I tried to end the game and return to the desktop, this happening with the previous version of CIS too.
Now that I disabled Defense+ this has also gone away.

I’m using Windows 7 x64.

Did you try that?
https://forums.comodo.com/defense-sandbox-faq-cis/app-is-not-working-correctly-but-does-not-seem-to-be-sboxed-what-to-do-v5-t61684.0.html;msg434597#msg434597

Thanks for that. The problems with Alcohol and Crysis were solved by excluding the folders of those programs in Execution Control Settings.

This works but it’s a workaround after all, and others problems may be caused by Execution Control.
I still haven’t decided if I’m going to use or disable Defence+.

Can you tell me exactly what you did as you seem to have hit on a magic combination that allows Alcahol 120 to run. Lots off other users are waiting for a fix! You must have used some combination fromn my FAQ tat no one else has! Even better can you send me a config report. Please see the red text in the standard format sticky for a link to the config reporting tool.

Well done!

Mouse

Moving to help so you can hep others…

Hi Im new here as well but I have found out the following with the alcohol 120% issues

  1. the new version 5 seemed to work fine with my windows 7 32bit laptop it installed fine no drivers emulation error at all !
  2. however my desktop with windows 7 64 bit was a issue ! 1st of all I kept getting the drivers / emulation error upon loading alcohol after I upgraded from comodo 4 to 5 so thinking alcohol was the problem I uninstalled and attempted a reinstall but then I kept getting a error on installation saying the installer was encountering a error and to contact alcohol support.
    After many hrs I stumbled across a fix.
    3.uninstall comodo completely then alcohol will install fine then as previously mentioned go to the defense +
    defense settings and exclude the alcohol exe in exclusion control settings after which both comodo and alcohol will both run fine.
    4.remember this only seems to be the case with 64bit windows 7 in my experience

hope this helps somebody :wink:

Well, I didn’t try many things. First I checked if Alcohol.exe was being sandboxed and it wasn’t.
Then I did as the FAQ said and entered “Defence+ Settings” and in “Execution Control Settings” I clicked “Exclusions” and added Alcohol.exe.
That worked when I started Alcohol but mounting disk images didn’t work outside Alcohol’s front end, for example I couldn’t mount a disk image in Windows Explorer.
So I went back to “Execution Control Settings”, deleted the exclusion of Alcohol.exe and added the exclusion of the entire Alcohol folder.
After that I had no prolem mounting disk images in Windows Explorer.

I don’t know if this is important but Alcohol is installed in D: not in C:\Program Files

Can you give me more information about the config reporting tool? Maybe I didn’t look hard enough but I can’t find much info about this…

The config reporter is here. You can ask it to generate an html file. If you zip it you can append it.

Thanks for saying what you did. Hopefully will help others. If not they can see if any other config might be helping.

Best wishes

Mouse

Even though I already posted what I did in order to have Alcohol 120 working with CIS, here https://forums.comodo.com/defense-sandbox-help-cis/alcohol-120-does-not-run-not-a-guardxxdll-issue-issue-256-t62075.0.html;msg440177#msg440177, I’ll repost it here.

In my particular case, I didn’t know how to fix it and I was trying several solutions, nothing worked. So, I uninstalled Alcohol. This action, caused me the grief, that I could not install again (the installer would hang with an error and that I should contact support). The technician from Alcohol Support, suggested to uninstall CIS 5 and reboot, then to get the latest version of Alcohol 120% 2.x, install it, reboot the PC, reinstall CIS 5, reboot, and then add the entire directory of Alcohol Soft in Program Files to the Defense+ exclusions for buffer overflow.

If you already had Alcohol installed before installing CIS, you just need to do the final step, by addingg the entire directory Alcohol Soft in Program Files to the Defense+ exclusions for buffer overflow.

Any errors with the SPTD driver or crash, disappeared after that, and Alcohol runs without issues.