Defense+ Bug??? (GameGuard Problem)

Version 3.0.25.378

I think I have found a bug in “Defense+ Settings” which incidentally “solved” my problem regarding GameGuard restarting the computer while authenticating. Posts of the same problem is found in razor74’s thread: https://forums.comodo.com/bug_reports/latest_update_ruined_functionality_of_some_mmorpg_games-t22022.0.html

I updated GameGuard by following 000000’s instructions found on page 7 of razor74’s thread but when I started the game that used GameGuard the same thing happened. My computer restarted.

What I did to solve the problem without rebooting was:

  1. Set the Network and Proactive Defense to “Training Mode”. It also worked in Clean & Safe modes
  2. Opened “Defense+ settings” (Defense+ - Advanced - Defense+ Settings)
  3. Checked “Deactivate the Defense+ permanently”
  4. Pressed “Apply” but when I was prompted to restart the computer I pressed “No”
  5. Then I reversed the process by unchecking “Deactivate the Defense+ permanently” without restarting the computer by pressing “No” again.

It solved the problem without restarting the computer. The game (FLYFF) started smoothly without rebooting the computer. I don’t know if this will work with other games.

My questions now are:

  1. Was Defense+ not affected by what I did?
  2. Was Defense+ still activated/functioning eventhough I did not restart the computer?
  3. Why did Defense+ allow GameGuard to run after I did the procedure mentioned above

I’ll try that also to see if it solves my problem. Thanks for the tips. :■■■■
EDIT: It worked here also but, you need to do those steps again when you restarts.

Hello Munemasa Katagiri,

Please let me know if it worked for you.

marinius

It worked, and you don’t even need to change their settings, just check the disable Defense+ box, don’t restart, and uncheck it again. The game opens and doesn’t reboot you. But, when you restart your computer, you need to do it again or Gayguard will reboot you.

This is happened with older versions of Game Guard. Witha Latest revision - 1196, D + work fine.

It’s up to the games’ plublishers to update Gameguard, some of them just don’t look like doing it.

Yes Munemasa, I forgot to add in my post that you have to do the procedure all over again when you reboot. Anyway, razor74’s news that GameGuard’s latest revision (1196) had solved the problem will put this “nightmare” to rest…enjoy your games…

marinius :BNC

Unfortunately the games’publishers must update their versions. (:SAD) Some of them are just lazy to do that. :THNK

Yes, that’s the problem with some of them…

Defense+
Registry key
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows]
“AppInit_DLLs”=“%windir%\system32\guard32.dll”

Deactivate the Defense+
Registry key
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows]
“AppInit_DLLs”=“”

What’s AppInit_DLLs
ttp://support.microsoft.com/kb/197571

So has GameGuard updated and fixed the computer restart issue for good?

I don’t have any personal knowledge with Gameguard lately because I have already deleted the game which uses it. But according to razor74 above, its already been resolved with revision - 1196.