Defense+ blocks Symantec Antivirus when cleaning infected files

Hi, I have two computers. One of them has windows XP SP3 and the other one has Vista SP1 (both machines are 32 bits systems).

In both computers I have Symantec Endpoint Antivirus and Comodo Firewall 3 with Defense+ in Clean PC mode.

Both things worked fine till version

Since that version (now I’m running and the problem persists), when I download an infected file and Symantec Antivirus tries to clean it, it can’t. In fact, it starts creating duplicate temp files infected in the quaratine folder with the same virus.

However, if I turn off Defense+, the virus is cleaned in the first attemp succesfusly (it doesn’t create any temp duplicate files).

Both machines are not infected as far as I know. I installed Vista yesterday and had the same problem, so I think it is not related to a virus/spyware in my computer.

Also as I say, when I turn off Defense+ the antivirus works without any problem.

I’ve tried with different infected files, but I always get the same problem.

With previous versions of Comodo Firewall I didn’t have this problem. Of course, when Defense+ asked me about Symantec Antivirus, I always chose “Trusted Application”.

I hope someboy can give me an opinion.

Thanks in advance (:WAV)

You need to add all Symantec files to D+ that are involved. Try putting D+ in training mode also.

Hi Vettetech,

First of all thank you very much for answering to my question.

What files should I add to D+? The whole antivirus installation folder, or only the executable files? Also, where should I add that files, through the “My own safe files” option?

I’ve changed to Training Mode and tried a infected file. The antivirus has deleted it well. I’ve also added in the “My trusted Software Vendors” the main process of Symantec antivirus (SMC.exe process).

Now I’ve changed to Clean PC Mode and tried with other infected file, and it seems to work well. However I don’t know if I’ll face this problem in future.

Do you know what has happened with the D+? Why the old versions of Comodo Firewall worked fine and now I’m having this issue? Is it due to a change in D+?

The first time I experienced this issue I though my machine was infected with a virus/spyware, but I’ve realized it is not true.

Thanks in advance.

Only the .exe files will do. If yo happens to find a .bat file you can put that in as well. Comodo warn for .exe and .bat files.