Defense+ blocks Firefox as a Trusted App.


my cis updated about yesterday and since, every time i open firefox it freezed for a minute or two and sometimes it crashed completly. defense+ listed an “blocked intrusion” every time as firefox “access memory” and the same for firefox’s plugin-container.exe. i added an picture from the cis log for better understanding.

firefox as well as the plugin-container.exe are “trusted app.” but still definse+ blocks them. please help me, i can’t browse as it is now =/

[attachment deleted by admin]

What version of FF are you using? Can you show us a screenshot of the Active Process List while FF is running with FF visible?

What your picture shows is the self protection of CIS. It does not mean FF is not trusted. Trusted Files area allowed a lot but not accessing CIS and other protected files in memory.

hi eric.
thx for your fast reply. i’m currently using firefox v.3.6.18. i made a screenshot of the defense active prozess list. i also did another one of the defense+ log, cause it seems any other program i start gets an entry, too.

[attachment deleted by admin]

The Active Process List show FF not being sandboxed.

What you are witnessing in the D+ logs is the self protection of CIS. Memory access to CIS files is not allowed; not even for Trusted Files.

Everything is working like it should.

thx again and again for your good support.
i was a bit worried, cause ff still freezes shortly and cause somehow all other programs i start seem to access cis and so it selfdefends…
but if you tell me everything works as it should be,i am at ease :slight_smile:

From the D+ you showed I see nothing that would indicate CIS is influending FF behaviour.

Try cleaning FF cache and restarting it helps to tackle the problem. Also consider letting FF clean cache on exit. That will keep it more responsive. Also try running FF in its safe mode to see if extensions are playing a role or not.

Last question. Does this only happen with FF browser and not with other browsers?

i always have ff sett up to clean everything when closing and usally use cccleaner for cleaning temporary files as well. i only use ff as a browser, so i don’t know if other browser are affected. the thing is, that when i open the cis main screen, in the defense+ area it shows the line: defense+ has blocked 31 intrusions so far and thats the log i posted.
since i last posted, every single program i used is listed there (as a blocked instrusion) with the flags “access memory”. ff was so far the only program that showed differences in behavious so i assumed some part of it was blocked by cis (+the log for the same times ff froze).

Not sure what is causing the memory access attempts by FF. I fired up FF 5, without extensions, to see if surfing would trigger memory access attempts. But it did not do such thing.

I am not convinced CIS is causing the hiccups you are reporting.

Are you using extensions? Please start FF in FF Safe Mode to disable them and see if that changes things.

Some older programming frameworks created executables that continuously accessed the memory of all other running processes. Basically just checking what is running I think.

Version 3 is an old version. I suspect that is what is happening. Idrive, which is based on old programming technology does the same. And Registrar Registry Manager. It’s nothing to worry about.

You can exempt the program from the check. But for a browser which could run malware that’s probably not wise.

Best wishes


i think i figured out the cause of the hiccups (great term for it btw =),
seems to be the new google word suggestion in combination with firefox 3. a friend of mine has the same problem with a different firewall and the plungin-container.exe seem to has some to do with it, too.
but i guess i leave it as it is for now :slight_smile:

thx u guys a lot! you can always count on this forum and on comodo of course ;D

sadly i have to re-open this topic. i updated firefox to the current since last time and it was working fine…at least some time. now i got the old problems, firefox freezing and hiccup-ing.

i was assured def+ should be working as it should, but the hiccup timing alsways fits the timing of firefox freezing. cis updated again and i hoped it would fix everything, but it seemed to worsen! now any programm i start, gets an defense+ entry under “def+ has blocked intrusions so far”. i can’t use my pc as long as def+ is running, disabling it changed nothing til the complete reboot + disabling it. i add a screemshot of the defense+ log.

as it is now, my pc works but only without defense+. at first only firefox and the plugin-container.exe got blocked or whatever, now my whole pc. please help, i feel quite unprotected!

[attachment deleted by admin]

I am not convinced the memory access attempts by FF or plugincontainer are the cause here.

May be left overs of previously installed security programs are in the way. Try using removal tools for those programs. Here is a list of removal tools for common av programs: ESET Knowledgebase .

Otherwise do a Google search with terms “removal tool” and * name of product or vendor*. Let us know if this helps or not.

We also need some extra information . Can you tell us what processes(es) are eating up your system’s resources? Does this exclusively happen when you run FF or does it also happen when other applications are running? Does it make a difference if you run FF in FF Safe Mode (with extensions disabled)?

besides cis i only installed ad-aware once. but it should be removed completly.

i restarted def+ with a reboot and tried ff in safemode with- and without add-ons and both worked without any noticable delays.

the thing is that since the restart of def+ everytihing works well so far. there are 14 intrusion attempt but no noticable delays this far, so it might really not be the memory attemps. may have been a one time only thing i hope…

still i’ll keep watch for processes eating up my resources. as far as i could notice at the moments the hiccup freezes occured, i was often on fb or watching some streams like movie trailer.

again thx for the support!

Seems like firefox is the reason for my problems after all. Tried some things without defense+ again and ff still bugged as hell normal and in safe mode. As suggested cis sems to be alright after all^^ ff is the only process with high memory usage,too.

Any idea what u can do?

Just out of curiosity, what are the settings for:

CIS/Defence+/Computer Security Policy/Comodo Internet Security/Custom Policy/Customise/Access Rights?

You mentioned you upgraded to the latest version of firefox, I assume you mean release version and not beta, if so, it means you’re using version 5.

The most common cause of memory problems with firefox, are conflicts between extensions/plugins. To ascertain how much memory firefox is using:

Run firefox, in the address bar type about:memory. Do the same by starting firefox in safe mode and compare.

add the process of firefox to the exceptions.

[attachment deleted by admin]

thx for your replies!

i was out of town for a while and in this time a friend of mine was using my computer. he found out that my gpu wasn’t working properly. the nvidea driver crashed some times and at a later point even video files seemed to be lagging. in his opinion the ff crashes were results of the graphic processes crashing.

i’m not sure wether he’s right, but i got a new gpu and installed windows new. as for now everything works fine =)

thx again for the support cis forum!