Defense+ Blocking Ceedo??

Hello All,

  I'm really not sure what part of CIS is blocking Ceedo ( ). I have tried using Ceedo on 6 PC's 3 with CIS and 3 without. The PC's without CIS Ceedo worked great the 3 with CIS Ceedo wont work. The operating systems range from Xp Sp3 32 Bit, Vista Sp2 32 Bit, Vista Sp2 64 Bit, Win 7 64 Bit. I was pretty sure CIS was the culprit so I took a laptop and wiped it clean. I loaded XP 32 Bit and all updates Sp3 and such. Then I tried Ceedo, it worked then I installed CIS with AV and Firewall. I tried again the Ceedo window comes up like it's trying to load but then closes and nothing else. 

I’ve tried to disable D+ and it still wont work. Ive even closed comodo then went to task manager and end task on all CIS process and it still wont work? I have looked at all the logs in CIS and can’t find anything showing it killing Ceedo.

Probably not many people here using Ceedo here but they do have a 45 day trial if anyone has a spare USB drive and wiling to test this. I will mention one thing I’m not 100% sure Ceedo is 64 compatible right now.

Any thoughts or suggestions would be appreciated.

Thanks, Mike.

Can you show us the logs of Defense +? They can be found under Defense + → Common Tasks → View Defense + alerts. That may give us a clue.

I’m afraid the logs do no good, sorry I forgot to mention that in my first post. I’ve looked at the AV logs and D+ logs and nothing is there. I will attach A D+ log just minutes after trying Ceedo to day 9/14/09. But as you can see there is nothing there for today??

[attachment deleted by admin]

I downloaded the trial version and tried to install it on my Win 7 system. It installs to the point where it says it cannot find a removable device even though there is USB stick present. The same thing happens when I completely disable D+ and reboot.

Is that what you are experiencing as well?

Yes, that is the same problem I was having. Since then I installed it using a PC without CIS and had no problem.

Now I’m trying to run it on a PC with CIS and it wont run, it tries to start then just goes away. Just like the installer, goes so far then stops.

It just bugs me how CIS will shoot it down without anything in the log files.

Thank you for trying this Eric.

I will move this to the bug boards so the devs will take notice of it.

Just to update this, I did install the new version 3.12.111745.560 and Ceedo still won’t load.


Hi, all.

My name is Keith Watson. I’m Ceedo’s support guy. I’d like to address the issues between Comodo and Ceedo, as well as Ceedo and 64 bit versions of Windows.

Unfortunately, Comodo and Ceedo do not play well together - if Comodo is installed on the host PC, Ceedo won’t run. The only way I’ve been able to get Ceedo to run is to uninstall Comodo.

Mike, it would be greatly appreciated if you could download a utility called Process Monitor and use it to obtain a log file to see what happens when you launch Ceedo (with Comodo installed on the host). This might point at where the problem comes into play. I’ll do the same on my end.

Process Monitor’s logs can wind up being pretty big, so if you can host your log files using a free file hosting site such as Dropbox ( and send me a download link, I can then get both sets of logs (yours and mine) to our QA team so they can compare the results, and hopefully come up with a resolution.

You can download Process Monitor from

You can find instructions for using Process Monitor to create a log file here:

With regards to Ceedo running 64 bit versions of Windows, right now, Ceedo is only available in a 32 bit version. 64 bit support is in the works, and a beta is expected soon. Hopefully the beta will be available later this month or early next month, but it could take a little longer. :slight_smile:

I have a mailing list for the 64 bit beta when it becomes available, so if anyone here wants me to add their names and e-mail addresses to the list, please e-mail me at, and I’ll add you. Don’t worry, you will not be spammed. I personally guarantee this! :slight_smile:



What if:

  • install Ceedo at the first place
  • install CIS
  • disable Defense+ permanently (Defense+/Advanced/Defense+ settings > deactivate permanently), reboot computer

…if Ceedo runs normally after reboot:

  • re-enable D+ , reboot
  • put D+ to “disabled” mode and untick “detect shellcode injections” under Defense+/Advanced/Image Execution settings.

if Ceedo runs normally now, chances are it can co-operate with D+ by tweaking some D+ settings.

Only one way to find out, I guess. :slight_smile: Don’t forget to create a restore point in Windows first, though.

I’m in the process of downloading and installing Comodo now, and will try the same thing. Just have to remove the “other” AV software first. :smiley:

Ok, Sorry for taking so long to get back to this but I’ve been waiting to get a hold of a 32 Bit machine. The 2 that Ceedo was working on are at work so I didn’t want to try to install CIS or the debugger on those and get into trouble :slight_smile: .

Any ways I just did what SS26 suggested. Ceedo worked with Defense+ permanently disabled but as soon as I re-enabled it and unticked shellcode it wont work. I get the following error “The application failed to initialize properly (0xc0150004). Click on OK to terminate the application” .

Now I will set defense+ back to enabled and check shellcode then run the process monitor like keithsa would like.

here is the log file I created with the process monitor.

[attachment deleted by admin]

Thanks for the log file, Mike. Much appreciated. I’ll get this into QA today.