Defence + crashing games even in game mode.

Since the last update of CIS if i play ANY fullscreen game or app even under game mode D+ crashes it after 15-30 minutes. I have verified this because with d+ disabled it does not happen and re-enabling it even with the game/app already running causes the game/app to crash within 15-30 minutes.

I originally thought this was a computer specific issue because it happened to 5 consecutive games. Then d+ was getting really annoying about a constantly updating application so i disabled it and as usual forgot to re-enable when the application updates were complete.

A couple hours later i realized the game i was playing at the time (crimecraft) had not crashed. I then tried a few other apps which had been crashing and they didn’t crash either. I remembered turning the d+ off and after enabling it presto went back to crashing the apps/games.

spent last couple days turning it on and off and rebooting/relogging to see if there were any other factors involved.

The only apparent factor is the d+ on any level other then disabled means crash Training mode has always crashed games usually because of the popup aspects when your in fullscreen not to mention when it blocks a fullscreen game it usually locks it too.

Edit by EricJH: made a paragraph structure for easier read

Hi Mad-one.Can you tell us a bit more about your system. What OS you are on,what other security programs are running in the background, are you using a clean or an update installation of CIS and what games are crashing?

Training mode doesn’t give you any popups, nor is anything blocked. Training mode creates ‘allow’ rules for any question it needs an answer for. If you’re getting popups or blocking while in training mode, something is wrong with your installation.

Game mode should also suppress popups, just as in training mode. However, the sandbox and the AV are still active, so I guess it’s possible to still get an alert from either of those modules.

Something you may try is to add the problem games to Defense+ → Defense+ Settings → Execution Control Settings → Exclusions. I know in the past, some games such as WoW aren’t happy with the BO protection for some reason.

Yet you can still have CIS steal focus in Game mode…
CIS steals focus in Game mode - full screen games are minimised [286] ← Still not fixed in 5.9

XP sp3 32 bit installed on gaming hardware no security programs other then CISC 2012. It was a clean instal originally 9/22/2011 after complete uninstal/clean of free version.

Soon after the install and folowing interactions with “geekbuddy” i started having major problems with system. Original reason for contacting geekbuddy was due to language being changed on my computer to what looked like webdings font to me. After language problem was resolved other problems popped up. Such as my windows audio service crashes at bootup and needs to be manually restarted. My volume control doesn’t usually load anymore. and various other issues which seemed to happen after the geekbuddy interactions with my system.

TBH in the last year or more i have spent more time with D+ offline then online due to the fact that 90% of the time when it takes focus from a game/fullscreen app and sandboxes it just crashes the game and freezes system, usually resulting in a forced boot to recover. The constant focus grab is what i always assumed to be the cause especially since most of the games have anticheat technlogy that kicks in when third party software interferes with the game.

There surely is something going on with your system. Did the Geekbuddy session learn what the cause was from the change of language? That may actually have been a change of font because if I recall correctly one cannot change the language of XP like can be done with f.e. Ultimate Editions from Vista and 7.

How was the problem solved by GB? What other issues are you talking about? Could you describe them in more detail. I want to see if there are also other problems than an apparent one with CIS.

heh if you have a moment to look up my other posts … all 5 of them or so … you will see the geekbuddy didn’t actually resolve much at all and after several attempts i just gave up. The only thing they did was switch the language back. When i later had an audio driver issue the geekbuddy rep literally duplicated the same process i had already done 5-6 times and after he/she did it 2-3 times it eventually worked … sort-of.

I even pointed out to a geekbuddy rep that my computer was suddenly running in selective startup mode only and any attempt to change to original boot goes straight into safe-mode. Said rep attempted to tell me this was normal hence why i simply stopped trying to get help from them.
Yes my system is a complete mess and getting worse. The whole thing started with that language change. It wasn’t just the display language. All the window labels system messages etc had changed too and it took me 5 hours long distance with a friend in order to get enough english back on the system just to contact geekbuddy.
Options disappear during reboot to come back 2-3 reboots later. I could swear i’m running on a virtual machine image half the time because when i do things like add words to my spellchecker dictionary they are no longer in it after a reboot.
My sound (speaker) icon loads up in systray 2 out of 3 reboots and only 1 out of 3 reboots does the windows audio service start correctly. Most of the time i have to manually start it.
Today i was going to allow my son to watch netflix on my second monitor only to discover that i’m suddenly only able to run clone mode or single mode.
Direct 3d such as 3d text screensaver suddenly appears as a blank white rectangle bouncing around screen with the message “no 3d device found” or something similar.
Windows update always freezes at 0% and eventually disappears without actually downloading anything.
The whole thing is especially frustrating as i’m in the middle of a civil case against my landlord trying to buy a house and dealing with legal issues in another case as well so i can’t afford to just buy a copy of win 7 and start over.
Geekbuddy sounded like a wonderful idea … until i realized that the people on the other end of the chat seem to know less then i do about computers and i don’t know very much …

Bah! Sorry i didn’t intend to vent like that. It sort of came out and i’m gonna post it anyways rather then delete it.

Mad

Well, I don’t think my issue is directly related to this subject, but since it involves lagging my game then I’ll talk about it . I “excessively” play MW3 and I can’t stand seeing something goes against the smooth game sessions of mine. When I installed the latest version, the game started to lag. I suspect that the issue comes from the fact that Comodo is sucking up a bit of resources. The latter was a reasonable cause, for me at least, to uninstall comodo. I had worse issues with AlterIWnet, google it, that the game wasn’t actually able to start. Let’s all hope that Comodo team gives us a more “mature” gaming mode so that we can all enjoy the top notch security, provided by Comodo, combined with smooth gaming sessions.

@ knk2006. Please start your own topic about this. The initial problem from Mad-one has changed to a completely different animal and I will continue with this and not the problem with games crashing.

At Mad-one. Thanks for your reply. This problem may be tough cookie to handle and in the process I will pursue various angles in an attempt to get to grips with it.

There is no need to follow the order of things to do. Feel free to do them in the order you see fit.

First angle is the angle to see if the file system is ok and when needed let Windows try to fix it. Start with running the command prompt → type: chkdsk /f → push enter (notice the space between chkdsk and f). Windows will now check the integrity of the file system and will also report bad sectors.

Let Windows check if the system files integrity. Follow the tutorial here: How To Use Sfc.exe To Repair System Files - Microsoft Windows Mini-Guides . Windows will see if all system files are there and if they have the proper version number.

Second angle is to have the condition of the hard drive examined. Start with reading the SMART status of your hd. You can use the freeware program Speedfan for this and have the status analysed on line. SMART stands for Self Monitoring Analyis and Reporting Tool. In short a hd analyses its state and that can be analysed.

Look up the maker of your hard drive and go their web site and download their test tool. Run it and see what it reports. Let us know if it reports bad sectors and how many.

Third angle is to vigorously check for malware using:

  • Comodo Cleaning Essentials. start it in aggressive mode by holding the the shift button when starting it. Then choose to let it also check for rootkits (reboot required)
  • Malwarebytes anti malware
  • Super Antispyware
  • Hitman Pro

The above list will keep you busy for a while. Keep us posted on how things are going. Feel free to report after every step of the above steps.

and i forgot to mention … my i386 files have been somehow removed from the windows drive …
so sfc wil be running off an sp1 cd which means all “restored” files will be unpatched versions. Oh and last time i attempted to force a reinstall of sp3 was a few years ago and it failed miserably

Well I’m using my phone to post this edit …as after I posted I decided to run the Comodo Cleaning Essentials as requested. After the initial reboot (1minute after the post) my system appears to have frozen.
I am looking at my desktop wallpaper on 2 monitors and nothing else not even the hard drives are moving…is this normal for “aggressive” with root kit scan?

That’s not normal behaviour with CCE. You can try to run the other scanners and see what they come up with.

With the i386 folder missing I am pretty close to advising to do a clean installation of Windows. Could you check the fitness of the HD to see if that is functioning properly?

Raid arrays test out fine.
I downloaded sp3 and extracted it borrowed a sp2 install CD from friend. Copied i386 folder from CD and then overlayed it with the extracted i386 folder from sp3 patch.
I then copied the completed folder (i386) to root of second partition of primary array and made required edits to registry in order to show it as original install location. Ran sfc and it reported no issues.
I then went back to CCE and ran it without rootkit check to see what would happen. Worked fine under aggressive mode. Yet when I tried again with rootkit scan, my system froze after reboot exactly as before.
Just for “fun” I tried a few more times and every time it tried to check for rootkit, it locked up my system right after reboot / login.
When I run Comodo Autorun Analyser there appears to be a lot of drivers missing INCLUDING language.dll and the Comodo backups dll or sys.

As for a clean install I simply cannot have the system offline long enough at this time to go through the 3-5 day process of reinstalling /updating the OS and the software I need for court documents etc. Tbh I would rather just install win7 but the copy I ordered from local shop never arrived and they went out of business so I couldn’t even get refunded. Right now due to preparing to move house about 100km I can’t even afford to think about spending.

EDIT:
Well all tat was posted with my phone while i was yet again wasting time with geekbuddy … went through 3 operators … they kept shoving me to the next guy and in the end they did nothing i myself hadn’t already done at least 50+ times … in fact when i brought up the CCE tool they didn’t even look at it. Nor did they do anything else but google microsoft fixes for immediate problems (which obviously i had already done) And at one point they were attempting to run windows update in SAFE MODE/networking … while constantly getting me to relog into various admin accounts because of the standard windows “you must be an admin to do this” messages from attempting to use 32 bit software in safe mode …even after i told them you can’t use it in safe mode

You really need to seriously rethink having “geekbuddy” doing your support.

Sorry to hear you are having a hard time getting your Win 7.

If CCE is not working then try a couple of other scanners to check for malware:
Hitman Pro
Malwarebytes Anti Malware,
Super Antispyware
Gmer anti rootkit scanner (it will show possible rootkits in red; don’t do anything when it found something just post a screenshot here).

Please also check your hard drive to see if it is still fit or not.

What problems are still happening?

Regarding the empty Autoruns entries. They cannot be related to Windows because sfc /scannow did not report any issues. They could be left overs from uninstalled programs or programs with a failed installation.

As stated in previous post arrays are fine. Hardware issues do not cause complete language changes.

Will run those utilities after this ■■■■ “license expired” bug gets sorted since this time it completely disabled my CISC so i’m currently running with 0 protection due to extortionist tactic… even though its paid for …

Issues still happening are microsoft update is failing to download. On further research and despite geekbuddy’s latest attempt, I have discovered this also started at around the same time as the system language was changed. The original issue i asked geekbuddy to help with and received ONLY the language switched back to english was to undo the changes which had been done to my system.

Apparently the BITS was disabled by whatever/whoever switched my system language to non english. Probably to prevent future updates from resolving whatever security hole was originally used. I’m assuming the same reason for deleting the system i386 files

Every reboot gives me 0-2 “generic windows service host error” popups.
At least 2/3 of the time when i reboot i don’t get the speaker icon in tray. Now 4/5 of the time the windows audio service fails to start at boot. This recently changed after last interaction with geekbuddy a couple of days ago. Video settings for multimonitors keep changing from all 3 options to 2 out of 3 apparently randomly. As this is only a recent issue i don’t have an approximate frequency yet. However i have noticed it ONLY happens when i’m in single view or clone view modes on reboot. Never when i’m in extended view. And the very interesting one … I use a spellchecker and after EVERY reboot ALL the words i added to my personal dictionary are gone almost as if my entire OS was running … sandboxed …

ran these the only thing that showed up was an entry which turned out to simply mean something had been removed except for a few registry keys.

running the gmer now since i missed it the first time i went through the list
my raid scan, smart drive scan and hd tool all said my hd’s are in perfect condition. Took awhile to do this since i chose to do the scan both on my own computer and on someone else’s comp just to verify it … 0 bad sectors across 4 terrabytes. i even scanned the data backup drives that haven’t been in my computer for over a year.

After geekbuddy finally resolved the issue with the failed key AGAIN i asked them if they could restore my missing BITS service. They spent about 4 hours combing through my comp . running the same things repeatedy (chdsk/sfc) … and told me i was missing files … Which i obviously had already figured out hence why i asked them to restore it. Turns out they discovered that the BIT Service has had some dll’s etc deleted from system… just like i had told them it had 4+ hours earlier.

Gmer scan completed no red entries

Edit here to avoid triple posting:
Sytem issues resolved as stated in https://forums.comodo.com/news-announcements-feedback-cis/license-expired-despite-cc-being-charged-again-t80847.0.html

Will start with the def+ problems again

sigh time to turn def+ back on and get frustrated some more.
heh heh
the joys of bughunting