Defence+ blocking safe program.

Hi, Defence+ isn’t allowing Samsungs (pre installed on NC10) performance manager to access the memory. I have added it to ‘my own safe files’ under the Defence+ tab, the I tried to add Samsung to my trusted software vendors and it says it doesn’t appear to be a valid signed executable.

Defence+ continually blocks this application. The block attempt counter just keeps adding up.

All help is appreciated.

Delete the rules you created for the programs, then set Defense+ and the Firewall to learning mode, see if that helps…


No, didn’t work, but thanks for your suggestion.

Have you tried making samsung a signed application ? perhaps that could help ?


Hi Montana,

What exactly is showing up in the block log?
Is the block Samsung performance manager trying to access cfp in memory?


Hi, I have this exact problem. I tried your suggestion but it did’nt help unfortunately;msg155412

Have you any suggestions on how to do this?

Under Defence+/Common/My trusted software vendors/Click on “Add” and then read from the running process or look for a signed Samsung executable.

Have you tried adding the executable to the exceptions list for CIS
You could try C:\ProgramFiles\Samsung* or something similar

[attachment deleted by admin]

Yeah, it’s not there. Trying to adding the program just comes up wit a message saying it needs to be signed. Also, when I try to add it to the exceptions, it says it’s already present.

This was also discussed in this thread, where I gave the same suggestion as Matty_R about adding the exe to the exception list. This should work and the program shouldn’t show up in the log anymore. I tested this method with Logitech’s Setpoint (mouse and keyboard software that wants to interact with CIS every now and then) and it worked ok.

Also, when I try to add it to the exceptions, it says it's already present.

That’s odd. And the program isn’t on the list, even though CIS says so? Then I’m at my wit’s end.

I followed the instructions you linked, and it worked. The thing is, I could have sworn I did the exact same thing previously, with no results. Oh well! I appreciate you advice. Also, I was using the training mode setting, so I have changed that too, as you advised.

Good to hear you got the problem solved! Maybe you had forgot to apply the changes earlier?