Defence+ Alerts Slowdown

Related to: https://forums.comodo.com/cfp_beta_corner/defense_alerts_slow_downs_fixed-t21768.0.html

What’s the status on this bug? Is it fixed (in an upcoming release)?

Thanks :■■■■

no dev to comment ? (:SAD)

To me its not a bug. The delay from the time you launch a program till the time Comodo responds and then you apply the appropriate rule then the program is given to you is only a mere 5 secs or so. You only get a delay once. Then once Comodo knows the program there is no more delay. I run Comodo on 2 pc’s with no troubles. Are you suffering a delay when you launch any and all your programs even after Comodo remembers them and stops giving you alerts for those programs?

No, only when comodo defence+ popup “remembers” a rule (or is in the process of “remembering”) if i uncheck the “remember” part it is instantaneous. And i have to disagree with you, because in previous versions (don’t remember which) there was no delay whatsoever. I don’t know if this has to do with comodo remembering everything in the windows registry… maybe if a file was used it was much faster.

I don’t know if there has already been some discussion concerning this specific problem, so I figured I’d post here since its related to slowdown and D+ prompts. Superantispyware acesses the memory of… hmm… Just about everything, hehe

So when you click on the target application (In this case Opera) to perhaps check some info like File version, etc… The prompt completely hangs and everything slows to a crawl, Possible App. crash. Sometimes Need a hard reboot.

[attachment deleted by admin]

Are you using SAS in real time mode? No need to run SAS in real time. Make SAS trusted in D+. Its hard for me to experience this cause all of my 250 programs are learned by Comodo and I don’t get any alerts unless I install something new. Then after the D+ alert you get a 5 sec pause or so till Comodo learns the program and gives it to you to use. This to me is not a bug cause it happens once, then after Comodo has learned the program there is no pause. Have any of you tried putting D+ in training mode? I run Comodo on 2 pc’s with no troubles as well as 10 family pc’s.

Ooops duh. Yeah you’ll have to forgive me. :wink: I run in paranoid mode mainly and all you have to do is set it to allow SAS interprocess mem access for everything and you won’t be promted again. I’m running several things, trying out different stuff. I’m not having any pauses now either.

I run Comodo on 2 pc's with no troubles as well as 10 family pc's.
I'm running in paranoid almost exclusively, except for when needing to install some of these Trusted apps. Can you beat that Vettetech ? ^_^

I am running it in training mode, and if it’s not a bug why didn’t it happen in previous versions, don’t tell me it is a feature! (:TNG)

Ive had Comodo installed since January and it has always behaved like you described.

I’m not experiencing any slowdowns now. It depends on your configuration. In my case I just needed to allow SAS. memory access without being prompted for it always. Computer security policy >select application > Acess rights > etc.

More on this issue is found at https://forums.comodo.com/empty-t21315.0.html

Sorry Mr Brian but I don’t find it an issue. It happens once then that’s it. Lets suppose you start “x” program. Then Comodo gives you a D+ alert about “x” program wanting to access the keyboard. So you then select allow and have remember checked off. Then the alert goes away and about 5 secs later so “x” program actually starts. No biggie I can wait. The next time I start “x” program I do not get a D+ alert cause Comodo knows its safe and “x” program is started without delay. Even after reboot no delay. Sorry but I fail to see the problem.

I agree it’s not a bug. But to the others who’ve written about this, and also me, it’s an issue. It’s 5 seconds on your machine, but about 18 or 19 on mine (I have older machine). If you’re not using ‘Installer or Updater’ on installations, this is really a killer. So I’ve stuck with v3.0.14, which does not have this issue.

My laptop is only a year old but my desktop is 5 years old. P4 2.4 overclocked to 3.06 GHZ with 1 gig of ram and 2 160 gig hard drives. I highly doubt its 18-20 secs. Why are you stuck with an older version. Once all your apps are learned there are no more alerts. I dont get any alerts at all unless I introduce something new. Why dont you install the latest version and let it learn all your apps. Better yet do what I did and manually add all your programs. That way there you do not get any alerts.

Same here, for those programs that I use regularly. Installation programs are obviously a different case. I don’t allow installation programs free reign, although of course you can do so if you wish. P.S. my cpu is older than your 5-year-old CPU.

I’m having a D+ rulebase with 275 app rules in it.
Only to apply the rules takes 20 seconds !! and 50% cpu (and i don’t have a 5 year old cpu !!).
So if i “remember” anything to the D+ rules than it also takes 20sec’s and 50% cpu to “learn and remember” so i’d call that slow.

Vista SP1 x32 (UAC) - 3.0.25

I got over 200 apps., but not that many rules yet. My alerts take 0.5 seconds to popup and not much more to figure out what it is. All your speed are belong to me. :stuck_out_tongue: My PC. isn’t anything close to “Latest & Greatest”