DEFECTS in CFPUPDAT ability and its GUI Error Messages. (5.3 update to 5.5) [Issue Report]

The bug/issue

  1. What you did:
    In place update of C.I.S VERSION

Was 5.3.45???.??? Which was the result of a new download and install onto New installation of Windows in February 2011
Now 5.5.195786.1383 as per MORE => HELP.
but 5, 5, 195786, 1382 from Cfp, CmdAgent and cfpupdate Product Versions
and 5.5.64714.1382 from Cfp, CmdAgent and cfpupdate File versions

  1. What actually happened or you actually saw:
    slow progress bar as expected until the final bit
    “Cannot copy Inspect.sys”

Nothing seemed to happen for 10 minutes - then I closed cfpudate.
CFP had been closed by update so I re-launched and repeated update.
Very fast progress bar till the end and no further “Cannot copy Inspect.sys”, BUT INSTEAD
“Cannot copy signmgr.dll”
CFP GUI had been closed by update so I re-launched.
MORE => HELP told me I had 5.5.195786.1383,

But CHeck for Updates told me updates were available.
Repeated update.
Very fast progress bar to the end until “Cannot copy signmgr.dll”.
But CHeck for Updates told me updates were available.
Repeated update.
Very fast progress bar to the end until “Cannot copy signmgr.dll”.
This sequence of “Cannot copy signmgr.dll” kept on repeating.

I consider it extremely bad that you told me what failed to copy,
but totally failed to tell me where you were copying from and where you were copying to.
If you had told me I could have investigated and fixed the problem myself.

  1. What you expected to happen or see:
    An update to version 5.5.something

  2. How you tried to fix it & what happened:
    Rebooted Windows when all else fails.
    Check for Updates told me updates were available.
    Very fast progress bar till the end then told me to reboot to complete Installation.
    Rebooted Windows.

SUCCESS - Check for Update told me I was up to date.

  1. If its an application compatibility problem have you tried the application fixes here?:

  2. Details & exact version of any application (execpt CIS) involved with download link:
    Product version WAS 5.3.43550.1216 MODIFIED 29/12/2010 01:41:50 CREATED 29 ‎December ‎2010, ‏‎01:41:50 3.49 MB
    Product version NOW 5.3.64714.1382 MODIFIED 11/08/2010 10:36:57 CREATED 29 ‎December ‎2010, ‏‎01:41:50 3.57 MB
    All the error messages etc were using the new CFPUDAT window,
    not the previous CFPUDAT which I had seen previously when trying for 5.4??? and had failed.
    At previous FAIL I had other priorities so had restored a Macrium Partition Image to neutralise any update remnants.

  3. Whether you can make the problem happen again, and if so exact steps to make it happen:
    NOT ATTEMPTED. No wish to uninstall 5.5 and attempt clean install of 5.3

  4. Any other information (eg your guess regarding the cause, with reasons):

A problem with the security settings that you use to protect your files.
I had normal protection in force, i.e.
Configuration default “Comodo - Internet Security”
Game Mode - never used - nothing showing
Sandbox = Disabled
Defense+ = Safe Mode
FireWall = Safe Mode
AntiVirus = Stateful

Files which caused problems :-

The tool “Everything” from Voidtools can see several instances of this,
but C:\Windows\System32\drivers\Inspect.sys is really strange with an unusual effect,
Everything can see in the MFT the path but cannot see any size or dates,
and yet Windows Explorer can see 91 KB created ‎06 ‎January ‎2011, ‏‎17:37:00,
Modified 11 ‎August ‎2011, ‏‎10:37:40, and Accessed 04 ‎February ‎2011, ‏‎18:38:43
One of the wonders of Microsoft, Access date ignores Modification ! ! !
Is there something peculiar about Access Permisions to prevent Everything from seeing the size ?

WAS 5, 3, 174622, 1216 SIGNED ‎29 ‎December ‎2010 02:29:42
NOW 5, 5, 195786, 1382 sIGNED 30 ‎June ‎2011 09:36:44
Both were created on 29 ‎December ‎2010, ‏‎01:42:38

Files appended. (Please zip unless screenshots).
A.V. is now updated on 8/11/2011 12:11:20 PM to 9707
File properties of Bases.cav
Before upgrade from 5,3* to 5.5* were
200,699,942 bytes ‎08 ‎August ‎2011, ‏‎21:57:45
After upgrade :-
‎202,776,442 bytes 11 ‎August ‎2011, ‏‎12:01:56

Your set-up

  1. CIS version, AV database version & configuration used:
    from 5.3.45???.??? to 5.5.195786.1383
    Old Bases.cav 200,699,942 bytes ‎08 ‎August ‎2011, ‏‎21:57:45
    New Bases.cav 202,776,442 bytes 11 ‎August ‎2011, ‏‎12:01:56 version 9707
    Configuration - Internet Security

  2. a) Have you updated (without uninstall) from CIS 3 or 4:

  3. a) Have you imported a config from a previous version of CIS:

  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):

  5. Defense+, Sandbox, Firewall & AV security levels:
    D+= Safe Mode, Sandbox= Disabled, Firewall = Safe Mode , AV = Safe Mode

  6. OS version, service pack, number of bits, UAC setting, & account type:
    Windows 7 Ultimate, SP1, 64 BITS, NO UAC (I trust Comodo), User with administrator rights.

  7. Other security and utility software installed:

  8. Virtual machine used (Please do NOT use Virtual box):


Thank you for your Issue report.

Moved to verified.

Thank you