Default Browser

OS: Windows 7 Home Premium

Since recently updating comodo to version I’m now unable to have this set as the default browser it seems, as any links I get sent (through skype mainly) now automatically open in Internet Explorer instead even if Comodo Dragon is open. Dragon was the default before the update and IE still isn’t (because it still alerts me to this when I open it). When I go through control panel to default programs Comodo Dragon doesn’t appear in the list (but it still shows my other browsers Firefox and IE). Is there a fix for this? Dragon is really the only browser I use now so its annoying to have to keep copy+pasting the links instead of being able to just click them.

Please and Thanks

Just found, by setting another browser as default (firefox) and then running Dragon and reseting it to default it now works properly again on links.