default browser for comodo virtual kiosk

hello. i searched the forum but haven’t found what i need. as the title says, i want to know if comodo virtual kiosk can be used with the windows default browser, chrome, instead of comodo’s dragon. and, if it’s possible, how to do it, because when i press virtual kiosk, it says that it has to install comodo drgon and silverlight from microsoft, but i want it to use chrome. thanks.

You’re right, but installing Dragon just a suggestion and of course it’s not necessary. You can use Chrome in virtual kiosk.

Virtual Kiosk has two faces. One is a classic desktop and the other is a tablet like environment in which apps from Google Store can be used. For the tablet like environment Dragon is needed to power it. When Dragon is not installed Kiosk will open in classic mode.

You can run Chrome in Kiosk without Dragon being installed.

firstly, thanks for your quick answers. but, “wisdom” i don’t understand :“but installing Dragon just a suggestion and of course it’s not necessary.” thank you.

and, ericjh, you said :“When Dragon is not installed Kiosk will open in classic mode.” and this is the thing: i run chrome in windows. i haven’t installed virtual kiosk and when i press it, it asks to install dragon and silverlight. is there a way to install comodo virtual kiosk without having to install dragon browser? if there is, what is it?!?! thanks again.

Hi rcata88,
When you select to open Kiosk, select no in the popup screen (Screenshot) and Kiosk will continue to open in classic mode.

Kind regards.

[attachment deleted by admin]

hey,thanks man. but my kiosk doesn’t appear like that. here it is, after i press virtual kiosk in main comodo panel.

[attachment deleted by admin]

It appears as if the ‘Do not show this message again’ box has been selected at some time previously.

See my reply 4 in the topic below.
CIS 6.1 Virtual Kiosk
Thank you.

hello. i don’t know what are you saying here “It appears as if the ‘Do not show this message again’ box has been selected at some time previously.”
as for the other topic you told me, i went there and the value for DontShowVirtualKioskWarn was already set to 0. i’ve rebooted after i went to regedit and kiosk is still acting this way. i forgot to say that i use comodo internet security premium v. 6.2.282872.2847

Under HKEY_LOCAL_MACHINE\SYSTEM\Software\COMODO\Firewall Pro\Configurations you should see the default/predefined configurations listed as 0, 1 and 2.

If you are not certain which configuration is active you can reset all configurations to the value of zero for the DontShowVirtualKioskWarn registry entry found in the right column for each.
This should then show the options box (Screenshot) regardless of which configuration is active.

HKEY_LOCAL_MACHINE\SYSTEM\Software\COMODO\Firewall Pro\Configurations\0\Settings.
HKEY_LOCAL_MACHINE\SYSTEM\Software\COMODO\Firewall Pro\Configurations\1\Settings.
HKEY_LOCAL_MACHINE\SYSTEM\Software\COMODO\Firewall Pro\Configurations\2\Settings.

Sorry if my message is not clear.
If you have reset the DontShowVirtualKioskWarn registry entries for all configuration profiles and still not seeing the options box, then I am not sure what is happening.

[attachment deleted by admin]

hello. i want to say it worked, finally. thank you very much and i wish you no virus/hardware/software problems whatsoever !!

That is good to hear, thank you for your wishes. :-TU
I think it would be good to be able to reset this from the GUI.

“I think it would be good to be able to reset this from the GUI.” what do you mean?

For either you or I to create a wish for this in the wishlist.
In the user interface settings to have the option to show or not show the options box when entering kiosk, to eliminate the need for registry edits.
Wishlist
Wishlist guidelines

oh, ok. i understood. well, thanks again for your time and help !!

You are welcome. :slight_smile:

Hi rcata88,
I have created a wish here for this option to be added to the GUI settings, to eliminate the need for registry editing.

Kind regards.

yes, ok. i also gave a positive vote.

Thank you.